Skip to Content

A working IoT cockpit has stopped loading data all of a sudden. (HCP trial account)

Dec 05, 2017 at 06:58 AM


avatar image

A working IoT cockpit application has stopped loading data all of a sudden. (HCP trial account).

I was able access the IoT cockpit to access my Device, Device types and Message type until yesterday but MMS cockpit has stopped loading all of sudden.

please note i can access the MMS cockpit and see the messages stored onto my database table.

Can you please help ?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Anton Levin
Dec 05, 2017 at 07:28 AM

Dear user, could you please be more precise here? In the text you write "MMS cockpit has stopped loading all of sudden" and then "i can access the MMS cockpit and see the messages stored onto my database table" which (to me) contradict to each other. What exactly you are not able to access? When asking a question, could you please provide some URLs, screenshots, logs etc? Otherwise, it is hard to provide some valuable assistance. Regards, Anton

Show 10 Share
10 |10000 characters needed characters left characters exceeded

Hello Anton,

Sorry for the confusion, here are the screenshots.

MMS cockpit screenshot where i can access the tables:

IoT cockpit screenshot where the Device type, Message types do not load up, which were loading until yesterday

iot-database5.jpg (142.6 kB)
iot-database6.jpg (139.5 kB)

Could you please re-check your account configurations for 2 possible causes of this issue described in the FAQ [1]?

[1] > IoT Cockpit > Why does the Internet of Things service cockpit display error messages telling me that entities cannot be loaded?


I have observed my settings, below is already set-up :

1. "IoT-User" role assigned to my user id for IOTMMS and IOTRDMS applications.

2. Trust settings -> Principal propogation -> Enabled.

Can you please help ?


From the IoT RDMS logs I see the following: "BadCredentialsException: The issuer of the received SAML2Response is not a trusted Identity Provider. There is no configuration for IdP ' trial accout%'"

Do you have custom IdP configured for your account? Could you please post a screenshot of of your SCP Cockpit > Security > Trust > Application Identity Provider ?


Here is the screenshot:

iot-database7.jpg (52.6 kB)

Then another spot to check is SCP Cockpit > Applications > Subscriptions > iotcockpit > Destinations > rdms

Check if yours is called "rdms" is of type "HTTP", its URL end with "../", proxy type is set to "Internet" and Authentication is "ApptoAppSSO", additional property "TrustAll" is set to true.


I dont have any destination set-up over there. Until now it was working without this set-up.

Do i have to maintain this ?


Well, that destination is created automatically when you first enable the IoT Service for your account and could only be removed/modified by the account owner. Try to re-create it manually, then. Click on "New Destination" and provide the settings I have mentioned above. Full URL is


This reply from Anton is the correct answer. Mentioning this as I cannot mark this comment as the correct answer.


I deleted my iotmms app and redployed it worked, i now have the rdms destination active for iotcockpit service.

Thanks for the inputs. Sorry I am new to this and hence my questions might sound illogical.

I am now able to run the end to end scenario, from actual Sensors to displaying Sensor data on the UI5 app.

Thank You.