Skip to Content
0

Problem with sending email to inbox using a distribution list.

Oct 19, 2016 at 10:06 PM

99

avatar image

Hi Everyone,

I'm using CL_BCS with a distribution list to send mails to the inbox of a SAP user ( business workplace ). I'm using CL_DISTRIBUTIONLIST_BCS to add the recipients and this is all fine.

Now this is my problem,

In the distribution list I have two SAP users, both are set up in SAP and have an external email address associated with the user.

When the mails are sent, one user gets the message as expected in his SAP inbox. The other user gets the mail in his external mail.

So I've removed the email address in SU01, so now the user has no email in ADR6.

BUT the mail is still going to the external mail.

So just where is it getting the external email from and why isn't it going to the SAP inbox, any ideas?

Thanks in advance,

J

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Vinita Kasliwal Oct 20, 2016 at 01:42 AM
0

Hi Jonathan

Can you please check in Su01d whats the default communication method chosen?

The email is generally picked from SU01d so removing from there should have fixed the issue but could be something to do with buffer

or it could pick up email from LDAP or the org unit of the user

Can you check in So16 you would see something called reset buffer Check in the Addressing tab in SO16 -Tr. SO16 >> Tab "Mail sy. grp." >> check the checkbox "Send to home Addresses of Users" If this is set, please uncheck it or you can try Forward mails to SAP system ID and test the behavior again. I found the issue similar to one reported in the below thread do check this one as well

https://archive.sap.com/discussions/thread/1685855

Let me know if my reply was helpful.

Regards

Vinita

Share
10 |10000 characters needed characters left characters exceeded
Jonathan Singleton Oct 20, 2016 at 06:13 PM
0

Thank you Vinita, the answer is in SO16. The check boxes on the Mail sys group were not set. But using the 'Address Check' button and looking at the 'Automatic Forwarding' tab revealed that the user had automatic forwarding switched on.

thanks again.

J

Share
10 |10000 characters needed characters left characters exceeded