Skip to Content
0

error While connecting c4c with S4H On-Premise via HCI

Dec 04, 2017 at 04:29 PM

216

avatar image
Former Member

Hi Experts,

I am trying to connect my c4c tenant with my s4 on-premise using HANA cloud Integration (HCI). While doing so i faced an error:

Error accessing service; Service Ping ERROR: Error when calling SOAP Runtime functions: SRT: Processing error in Internet Communication Framework: ("ICF Error when receiving the response: ICM_HTTP_CONNECTION_BROKEN") ()

This error is occurring for all the scenarios. Please guide me on what could have possibly gone wrong. error-screenshot.jpg

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Sriprasad Shivaram Bhat
Dec 05, 2017 at 06:28 AM
0

Hello Priya,

Could you please check the url which you are using in communication arrangement.

It should be IFLMAP address like below.

https://XXX-iflmap.avtsbhf.XXX.hana.ondemand.com:443/cxf/<path defined in sender channel of CPI>

Also once you trigger the connection test from Communication arrangement after checking above and able to see failed message in SAP CPI with below error then connectivity is fine and you can ignore the error message in C4C ping test result.

Regards,

Sriprasad Shivaram Bhat


sap-sdn-c4c-ca.png (28.9 kB)
Share
10 |10000 characters needed characters left characters exceeded
Sriprasad Shivaram Bhat
Dec 05, 2017 at 03:09 AM
0

Hello Priya,

Where you are getting this error? In CPI?.If yes please share your communication channels screenshot.

Regards,

Sriprasad Shivaram Bhat

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Sriprasad,

this error I am facing in C4C system under Communication Arrangements while checking the outbound Connectivity.

0
Former Member

Hi Sriprasad,

I established the connection. The error was due to not opening ports in the S4 system.

Thank you for your valuable feedback!!

2
Juan Carlos Camacho Garduño May 08 at 11:36 PM
0

Hello!

Just to share our scenario

My team already faced this issue, actually it remains in our system, but everything works ok.

*The error comes after click 'Check Connection' on any communication arrangement.

This note explains the issue.

"This is expected behaviour. You need to replicate actual data to check if the scenario works. In case you get different errors than the above described or if you have failed messages in Web Service Message Monitoring, check the error context of the failed message to get more information on the error."

2604833 - ICM_HTTP_CONNECTION_BROKEN Error When Checking Connection in Communication Arrangement

https://launchpad.support.sap.com/#/notes/2604833

Regards!

Share
10 |10000 characters needed characters left characters exceeded