Skip to Content
0

XK99 Mass vendor Withholding Tax Accounting creation

Dec 04, 2017 at 02:02 PM

92

avatar image

Hi experts,

I'm trying to create Withholding Tax Accounting using XK99 but I'm getting the following error: "Field LFBW-WT_WTSTCD(1) is not an input field"

My company is in Brazil and the field LFBW-WT_WTSTCD is blank for our WTH tax.

I have followed the steps mentioned in thread below, selecting the field LFB1-QLAND. But it's still getting error.

https://archive.sap.com/discussions/thread/3763787

xk99-1.jpg (49.7 kB)
xk99-2.jpg (28.5 kB)
xk99-3.jpg (45.4 kB)
xk99-4.jpg (43.8 kB)
xk99-5.jpg (36.5 kB)
xk99-6.jpg (40.2 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Jürgen L
Dec 04, 2017 at 02:24 PM
0

the error message is talking about a field which you have not selected (I marked it green in your screenshot):


wtt.png (235.6 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Jürgen L, in this case, I don't have a number for this field.

In XK01 or XK02, we haven't ever updated this field before. It's blocked for changes.

Even so, I've tried to inform something into this field using XK99 but it's getting the same error:

xk99-7.jpg (83.8 kB)
xk99-8.jpg (41.6 kB)
0
Jürgen L
Dec 04, 2017 at 03:46 PM
0

Those fields are open for maintenance in my system, can you please check the settings for them in the field selection for each entry in customizing transaction OMSX

Show 3 Share
10 |10000 characters needed characters left characters exceeded

All fields are opt.entry:

omsx.jpg (45.6 kB)
0
Erich Andreu Salles Kimura

I said any entry, this is "change vendor accounting" corresponding to FK02

Mass creation with XK99 should be correspond to "create vendor centrally"

Also I am not sure if this message is really an error message or just information as you are in a test mode.

0

Hi Jurgen,

All entries are open for maintenance.

And no difference when executing as "Save mode":

omsx-2.jpg (47.4 kB)
xk99-9.jpg (32.7 kB)
0
Jürgen L
Dec 04, 2017 at 04:28 PM
0

I just tested it in my system and it worked like a charm.

I guess your system is not up-to-date with OSS notes. I see for example that your LFBW-WT_EXNR is still 15 long, while mine is 25 long

you may have to implement this note and probably even more: 2369535 - Segment E1LFBWM: new version of segment type for 'Exemption certificate number'

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Jurgen L,

The problem is in transaction OMSG, where the fields are suppressed.

I've changed to optional and the problem has been solved.

No OSS needed. Thanks!

omsg.jpg (54.3 kB)
0