Skip to Content

Connecting SAP Web IDE to on-premise

Dec 05, 2017 at 04:13 PM


avatar image

Hello experts,

I just managed to connect the SAP Web IDE to an on-premise S/4HANA system using the Cloud Connector.

Then I created a new project from template in the Web IDE that uses the OData Service as shown below:

When I run the application I get an error telling me that an exception occurred:

When I test the odata uri with metadata it looks fine:


the error occurrs when I try to bind the data in my view.xml or when I try to perfom an action on the data like for example:


here's also a view to the

Please give advice how to solve this problem.



odata.png (95.0 kB)
7exyd.png (114.8 kB)
rwaik.png (125.6 kB)
iukxx.png (172.3 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Bartosz Jarkowski Dec 05, 2017 at 04:43 PM

I think your WebIDE connection is working fine.

The problem is with OData service - in the rwaik.png file you can see the error saying "Maintain area of responsibility". I'm not an expert in any functional problems, but I'm pretty sure that when you solve this problem the error will disappear :)

You can test also on a different entity:


10 |10000 characters needed characters left characters exceeded
Georg Peters Dec 05, 2017 at 05:28 PM

Hi Bartosz,

thanks for your quick reply.Testing with /sap/opu/odata/sap/PP_MRP_COCKPIT_SRV/Suppliers/$count

shows another error (no service for namespace '', Name 'OPU', Version '0001' found)

and for the other error about the maintenance of area of responsibility, I just don't know what and how and where to fix it... any idea?

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Could you please go to your Gateway system, open tcode /iwfnd/maint_service, click on the PP_MRP_COCKPIT_SRV and post a screenshot?

Regarding the area of responsibility, sorry but I have no clue. I would ask someone with a functional knowledge... But you can also try to google:

Georg Peters Dec 05, 2017 at 07:37 PM

Problem is solved.

I had to specifiy the sap-client since there are more than one client on the same server. If one thinks about it, it seems obvious but the error message was quite misleading...

here is the point where you specify the sap-client on the SAP Cloud Platform:

10 |10000 characters needed characters left characters exceeded