Skip to Content
0

PowerBuilder 12.6

Dec 04, 2017 at 08:09 AM

145

avatar image
Former Member

Hello,

I've a PB Classic 12.6 application which use a DLL written in .NET.
If I use myOLEObject.ConnectToObject('mydll.class') it seems to work pretty well after deploying, but I get an error -3 if I start directly on powerbuilder for debugging the application.

The dll is correctly registered, I also tried to install it in the GAC cache, and even if I can now remove the dll from the deployed project path and run "normally" without errors, I still get error -3 when trying to start the application from Powerbuilder.
I've tried to put the dll in many paths (windows/system32, Program Files\Sybase\PowerBuilder 12.6) but I still get the same error.

What else can I try to make it work also directly from Powerbuilder ?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member
Jan 09 at 02:32 PM
0

Hi,

Similar issue was fixed in latest PB 12.6 build 4166.

You can download it from the SAP site.

Kind Regards.

Abdallah.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello,

I just upgraded PB 12.6 to build 4166.

Unlucky I got the same error while trying to debug.

Is there something else I could try ?

0
avatar image
Former Member Jan 10 at 02:01 PM
0

Hello,

I just upgraded PB 12.6 to build 4166.

Unlucky I got the same error while trying to debug.

Is there something else I could try ?

Share
10 |10000 characters needed characters left characters exceeded