Skip to Content
0

Issue with filters in smart table

Dec 01, 2017 at 03:41 PM

227

avatar image
Former Member

Hi experts,

1.I have a smart table .And it is working fine I can select/deselect no of columns according to number of properties in entity set.However when i press the filter tab.In the dropdown only the first property is populating(I expect filter wrt to all selected column should be there) .And I am unable to filter also.

2.I have given table type as Table(ui table).How to set ui table's property such as selection mode to none.

Thanks in Advance

 <smartTable:SmartTable entitySet="Myset"
 tableType="Table" useTablePersonalisation="true"
useExportToExcel="true" showRowCount="false" header="RS fos summary"
initiallyVisibleFields="prop1,prop2" exportType="GW"
	enableAutoBinding="true" demandPopin="true" class="sapUiResponsiveContentPadding">
</smartTable:SmartTable>
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Arjun Biswas Dec 02, 2017 at 03:20 AM
1

Hi ,

1. For filtering your smart table, make use of the smartFilterBar control as follows:

<smartFilterBar:SmartFilterBar 
		id="smartFilterBar"
		entityType="Product">
		<smartFilterBar:controlConfiguration>
			<smartFilterBar:ControlConfiguration
				key="Category" visibleInAdvancedArea="true"
				preventInitialDataFetchInValueHelpDialog="false">
			</smartFilterBar:ControlConfiguration>
		</smartFilterBar:controlConfiguration>
	</smartFilterBar:SmartFilterBar>

Please refer to the foll. link on filtering smart table data :

https://sapui5.hana.ondemand.com/1.36.6/docs/guide/1daa46220969467faf04329308c24613.html

2. For changing the selection mode, you can use the setSelectionMode method with your table object and in the parameter pass the selection mode you want as a string format.

Hope this helps,

Regards.

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

HI Arjun, Thank you for your response.

1.I have set selection mode property now.

2.Coming back to filter.I saw in SAP explored, in one of the samples without any filter bar .All the properties in odata are appearing in filter tab. but for me its not.

sample smart table with out any filter bar.

3. Iam exporting to excel and is working fine but in header it is mentioning property name and I want sap label as headers.

Regards

0

Hi Dilip rao K,

2. I guess there is some error that might have crept in while you are binding your annotations to the view. Maybe it is an backend issue, and there is nothing wrong in the UI part.

3. To use SAP label as headers, I would suggest you store the SAP label in an variable and then export them as header to your excel.

Regards.

0
Shweta Jain May 18 at 02:16 PM
0

hi , were your able to resolve this error ?? How

Share
10 |10000 characters needed characters left characters exceeded