Skip to Content
0

SFTP stopped working after 4.2 SP4 upgrade--zero byte file

Nov 29, 2017 at 10:48 PM

86

avatar image
Former Member

I have several SFTP sites that BOE has scheduled reports and sends data to on a regular basis. They all worked when the BOE server was at 4.2 SP02 in October 2017. I upgraded to 4.2 SP04 mid-October. All SFTP sites are working now except one. This particular site will send data but it will be received at the destination site as a 0 byte file. The fingerprint is correct because it worked with SP02 and it does send the file but, again, with 0 bytes. BOE reports the report instance as failed. The destination site is using Ipswitch SFTP Server. I sent the Network Manager the correct settings for one of the sites that works and he verified that his site had the same security settings. Additionally, using WinSCP directly on the BOE server to send the file works fine also--the file size is correct. Our firewall team ran a trace and the sftp send via BOE had the same results from this non-working site as with all of the working sites so there are no firewall blocks.

Any ideas on what to do to fix this?

10 |10000 characters needed characters left characters exceeded

If you use multiple SFTP sites and all work, except one - then logically, it is not an issue with upgrade, it is an issue with that specific site.
Something is different about it.
To investigate this you'll need to run end to end trace of the schedule to sftp workflow to this site and to one that works and compare the traces.
Also, run wireshark/network trace of the same and compare again.
There has to be a difference.
Use single same sample report for simplification.

0
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Sateesh Kumar Bukkisham Dec 05, 2017 at 02:23 PM
0

Hi Grone ,

we too observing same issue , I've raised thread to SAP ,but no solution .

https://answers.sap.com/questions/301070/bi-42-sp3-schedule-to-sftp-with-ssh-2-security-is.html

Regards

Sateesh

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I just saw your question on the community. It appears to be the exact same problem that I am experiencing. Have you made any progress?

0
Henry Banks
Dec 05, 2017 at 02:40 PM
0

Hi,

please contact technical support for this kind of investigation

kind regards, H

Share
10 |10000 characters needed characters left characters exceeded
Leslie Mui
Dec 20, 2017 at 05:40 PM
0

Approximately how large is the csv file for 27 days?

Could you shoot me an email at leslie.mui@sap.com with the incident #?

Is the SFTP destination off-site (fairly far away from the BI servers?)

If it's the same cause as Sateesh's issue, the difference in behaviour is a result of the change in Note 2346469.

I have a good guess as to what the problem is, but it'd need some testing

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Just an update, I forwarded Celeste's incident to development under Note 2581781

https://launchpad.support.sap.com/#/notes/2581781

The Note isn't currently public, but I expect it to be published in the next day or so.

The developer assigned will reach out to you via the incident if more info is required Celeste.

0
avatar image
Former Member Dec 20, 2017 at 03:33 PM
0

I do have a technical case open but am hoping for other information from the community.

After further investigation and testing, I found that it is not the sftp site but rather the size/selection of the query to create the file. The file is in an .csv format. The query (prompts) to create the file normally uses 90 days and creates the 0 byte file. When I set the query to 27 days or less, it worked and sftp'd the file correctly. When I set it at 28 days or more, it fails in BOE and sends a 0 byte file to the vendor sftp location.

No resolution yet, but at least I have made progress on narrowing down the issue.

Share
10 |10000 characters needed characters left characters exceeded
Leslie Mui
Jan 02 at 05:53 PM
0

Just answering this for closure.

I shot this over to development under Note 2581781

https://launchpad.support.sap.com/#/notes/2581781

It's a coding error and will be fixed in future patches on both 4.1 and 4.2

The fix levels for the issue will be updated in the Note once the patches containing the release are available for download.

Cheers,

Leslie

Share
10 |10000 characters needed characters left characters exceeded