Skip to Content
Nov 29, 2017 at 10:48 PM

SFTP stopped working after 4.2 SP4 upgrade--zero byte file

385 Views Last edit Nov 30, 2017 at 02:36 PM 2 rev

I have several SFTP sites that BOE has scheduled reports and sends data to on a regular basis. They all worked when the BOE server was at 4.2 SP02 in October 2017. I upgraded to 4.2 SP04 mid-October. All SFTP sites are working now except one. This particular site will send data but it will be received at the destination site as a 0 byte file. The fingerprint is correct because it worked with SP02 and it does send the file but, again, with 0 bytes. BOE reports the report instance as failed. The destination site is using Ipswitch SFTP Server. I sent the Network Manager the correct settings for one of the sites that works and he verified that his site had the same security settings. Additionally, using WinSCP directly on the BOE server to send the file works fine also--the file size is correct. Our firewall team ran a trace and the sftp send via BOE had the same results from this non-working site as with all of the working sites so there are no firewall blocks.

Any ideas on what to do to fix this?