Skip to Content

Important: SAP GUI for Windows 7.50 PL 3 Delivers No Session Object

Nov 29, 2017 at 08:22 PM


avatar image

Yesterday night I checked some SAP GUI Scripting programs with SAP GUI for Windows 7.50 PL 3, but without success. I was tired and I think, okay, try it again tomorrow. Today I tried it again, but with the same result. So I tried different ways (PowerShell, PureBasic and VBScript), but all without success. Each time delivers the access to session 0 an error.

Here my test environment on Windows 10, an open SAP Logon and one open session, with the index 1 in the status bar. In foreground a VBScript editor in debug mode. It delivers at line 14 an error:

The enumerator of the collection cannot find en element with the specified index.

It seems that this is a bug. Scripting Tracker, which runs in the same environment with PL 2 without any errors, doesn't work anymore with PL 3.

Thanks for tips and hints.


noenumerator.jpg (163.8 kB)
10 |10000 characters needed characters left characters exceeded

Have you tried adding 0 (zero) to the index? i.e. literally 0+0


Hello Daniel,

thanks for your reply. But this seems not to be a solution. I check now the standard script recorder and playback function, but it isn't possible to record a script. As it seems at the moment the SAP GUI Scripting is totally disfunctional in my environment.

I checked the SAP GUI installation and the check routine breaks at SAPsdcc.OCX.

Best regards

sapsdcc.jpg (92.9 kB)
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Stefan Schnell
Nov 30, 2017 at 03:58 AM

After a complete new installation all works now as expected. I don't found any reason for this behaviour.


10 |10000 characters needed characters left characters exceeded