$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
0

EPMMemberProperty refresh on load

Oct 19, 2016 at 03:59 PM

84

avatar image

Hi,

I have an EPM 10.1 input schedule in which several of the EPM reports reference a cell with the following formula:

=EPMMemberProperty("[Model]",[Dimension],"[Property]")

While testing we noticed this cell was not refreshing on load of the excel file. Specifically we modified this property, in the dimension, performed a full process, but noticed on load of the workbook the prior property value was retained.

Our solutions was EPM > Options > Sheet Options > Refresh (tab) > "Refresh Data in the Whole File when Opening it" (checkbox)

Is there a better way to do this?

Is there a way to set this to a system default?

(Having discovered this we're going to need to update all of our worksheets).

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

John Leggio
Oct 19, 2016 at 06:09 PM
0

Hey Jon,

In the EPMXLClientPreference.XML file ( under C:\Users\<USERNAME>\AppData\Local\EPMOfficeClient ) , change the value of this setting to true for all the users you want this setting to affect:

<RefreshOnOpen>false</RefreshOnOpen>

i.e.

<RefreshOnOpen>true</RefreshOnOpen>

Share
10 |10000 characters needed characters left characters exceeded
Jon Morisi Oct 19, 2016 at 07:33 PM
0

Is there a template or some location where I can configure this to be the default for new EPMXLClientPreference.XML files?

We're nearing the end of our 10.1 upgrade project and client installs have not yet been completed (we're actually publishing via Citrix).

It would be great to change this once vs each time a new end-user generates an EPMXLClientPreference.XML file (we have hundreds of end-users)

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Please talk to your network administrators to create a script that will set this option (patching EPMXLClientPreference.XML file) each time user will login to windows server... I don't think there is a better option!

0
Priyanka Jagtap Oct 20, 2016 at 06:58 AM
0

Hi Jon,

How much is the data in the template? have you done any analysis testing on the same? Is this persistent with only one workbook or all workbooks?

We had faced a similar kind of issues....but the template was heavy(large data volumes). We had used the options "Clear metadata Cache" and "Refresh Metadata for current connection" from More option in EPM! You can also schedule the clear metadata cache as per your requirement after 10 days 15 days etc... from the User options! It would be user specific then....You would have to ask the users to do the settings in their EPM.

Regards,

JP

Share
10 |10000 characters needed characters left characters exceeded