Skip to Content

SAP WEB IDE doesnt pull the latest metadata after changes to the Odata service

Nov 29, 2017 at 06:09 PM


avatar image

we have a service developed and we are tying to create a UI5 application in Web IDE. Now as and when the changes are made to the Service, when we try to update the metadata.xml file via odata service import, the metadata file created doesnt reflect the latest status of the fields.

Is this a cache issue or what is the issue with this? Please advice.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Jamie Cawley
Nov 29, 2017 at 08:56 PM

Sounds like you need to clear the cache on the gateway system using /IWFND/CACHE_CLEANUP and maybe /IWBEP/CACHE_CLEANUP on the backend.



10 |10000 characters needed characters left characters exceeded
Selvakumar Mohan Dec 01, 2017 at 02:35 PM

Yes that did help in bringing the latest metadata to the hub system, but still had issues with Web IDE, I was using Web IDE on chrome and even content clearing didnt help.

Later tried using firefox. I was able to get the latest content, SAP should consider about refreshing the metadata with a right click and refresh metadata from the service, its really tedious to each time import the service as new oData service and then replace the existing meta data file with new one.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thanks Selvakumar! We have it in our plans :)

Cc: Yuval Morad


That would be really awesome.