Skip to Content

NW 2004s ABAP - bugs in WS Client Proxy generation?

Hi!

I came across situation like this:

I exposed a web-service from the Sybase SQL Anywhere database (piece of cake - by the way!) and tried to consume this service from NW2004s ABAP. I have got almost a proper result like this:

The return parameter was an internal table LS_OUT-SOAPRESULT-ROWSET-ROW (I'll call it ROW further in the text). It had the correct number of rows, but only one field: a table-field called CONTROLLER, containing nothing. There were no values which correspond to the columns of the database table.

However, I could saw in a tunneling program that the SOAP message was correct - the values were there!

Then I consumed the same service from Java (just Java, not SAP NWAS Java) and got a correct result: the Row object was an array with correct number of members (the same as number of rows in SAP's ROW), but as opposed to ROW, it also contained the needed values in an object array called SOAPElement.

My guess is that SAP's Proxy generator "forgot" to include field(s) in the structure of the ROW internal table. I can only guess that there should be a table-field called SOAP_ELEMENT or similar.

Did something like this happen to anyone else? Is there something better to do except to program the service call manually?

Please share experience.

Thanks and regards,

Igor

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 25, 2008 at 07:20 PM

    Hi,

    i have the same experiences.

    Sometimes the proxy classes are not created properly.

    I have tried to change the proxy but the error was still there.

    Just delete it and create it from the beginning.

    regards

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi, Wolfgang!

      Sorry for late reply - I wasn't dealing with the subject for a long time.

      Even if there's no solution, nice to hear that I am not the only one experiencing the problem. It doesn't work. I can delete and generate the proxy over and over with the same result.

      Did delete/create work for you?

      The only option that I see left is to compose SOAP request manually and then parse the response by using transformations. This way I don't take the advantage of the new technology - I stay at the 620 level. But what can I do? The new fancy stuff simply doesn't work.

      Igor

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.