Skip to Content
0

Can not TECO Service Order(IW32) and giving runtime error: DUMP_STATUS_INCONSYSTENCY_FRE

Dec 01, 2017 at 03:32 PM

266

avatar image

Hi,

We are getting Runtime error when trying to TECO a Service Order(IW32).

Runtime error : The termination occurred in ABAP program "SAPLCOZV", in "CO_ZV_CONSISTENCY_CHECK". The main program was "SAPLCOIH".

When i check in Debug mode, AFIH-IPHAS = '3' (Technically completed), whereas JEST table Status does not get updated with I0045 and hence it is giving runtime error as DUMP_STATUS_INCONSYSTENCY_FRE/DUMP_STATUS_INCONSYSTENCY_ERL.

If i run ZIPHAS00(As per Note: 157070) for the above Service Order, Status inconsistency got corrected and then it is getting TECO successfully.

We are not able to understand why the system status has inconsistency which causes Runtime error.

I have searched in SDN, but did not find suitable clue and hence seeking for expert advise...

Thank you in advance.

Regards,

Kumar

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Raymond Giuseppi
Dec 04, 2017 at 02:11 PM
1

Did you look for (wild) call of STATUS_CHANGE_INTERN in some customer development, look in exit and BAdI. Then suggest abaper to use of BAPI_ALM_ORDER_MAINTAIN in a task. In some case you should also look for (wild) COMMIT in those BAdI/Exit that break the database integrity.

  • To trace log of status, look at table JCDS. You wont find trace of any most wild open-sql update but you should find trace of FM call.
  • You should also compare change in CDPOS/CDHDR of the order and values of JCDS, look for date/time change on order flag without correspondent record in JCDS and vice versa.
Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Raymond,

Thank you for your reply.

There are no new custom changes found in BADI/Exits related to Service order. And we are getting this issue when we do manual TECO in Service Order. Once we fix this issue we can go for using BAPI_ALM_ORDER_MAINTAIN in a task.

We are not able to find any changes in CDPOS/CDHDR so far w.r.t JCDS.

Thank you for your time.

Regards,

Kumar

0

If this issue occurs in standard SAP transaction then please contact SAP Support.

0
Peter Atkin Dec 02, 2017 at 06:15 PM
0

Kumar,

This doesn't happen very often.

In most cases i've come across its been self-inflicted whereby someone has updated the system-status via a function module (but not the order IPHAS data).

PeteA

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Peter,

Thank you for your response.

This issue is happening for all of the Orders, Is there anyway we can find who has updated the system-status(JEST) via a Function module? OR

Any solution to correct JEST status in order to make it consistency with IPHAS data.

Thank you.

0
Jelena Perfiljeva
Dec 01, 2017 at 11:12 PM
0

Is this a recurring issue? If not then just move on. If there was an answer SAP would've fixed it permanently already. If there is no correction note and just a report to fix it then file it under the unexplained SAP mysteries.

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Hi Jelena,

Thank you for your response. Yes, it's happening for all of the Orders(Manual TECO & thru BAPI Calls) and hence we are worrying. Currently this is happening in Development System, as we are doing Integrations for Work orders and need to move our Transport to Quality system for further testing. Unless we fix this issue in Development we can't move Transport to Quality system.

Can you please suggest any SAP Correction available for this issue.

Thank you.

0

Not sure what "doing Integrations" mean exactly but if you have done some custom development and this started happening afterwards then wouldn't it be logical to suspect that something got broken by that custom development? Such things don't just happen all of a sudden (when it's a consistent problem). Some change must have occurred.

Sorry but information in this post so far doesn't give us much to work with as you're only sharing a symptom.

In general, you can use ANST transaction to find applicable corrections but based on your comment I suspect this is not a standard SAP issue.

0

Hi Jelena,

I mean 'doing Integrations' is that we are working on project where developing RFC's related to Service Order creation etc.. Used standard BAPI's for our development and we have not done any custom development(Not touched user exit/BADI) related to Status changes.

When we tried to do TECO for Service Order, it's given Status Inconsistency Run time error.

Informed our team to look further and check for any suitable correction notes for status inconsistencies.

Will update if we find any solution for this.

Thank you.

0

It's still not clear when exactly the termination occurs. If you are calling a BAPI to change the service order status and get a short dump then wouldn't you think that a BAPI name and corresponding code would be pertinent information?

Please review this blog and see how you could help to have this question answered.

0
Jelena Perfiljeva

Hi Jelena,

We found the root cause for the run time error. There is another developer who is working on Status updates and used Commit statement in User-exit. We have removed the commit statement and now successfully able to complete TECO.

Thank you all for your valuable inputs towards this issue.

Regards,

Kumar

0
G Lakshmipathi
Dec 04, 2017 at 02:43 PM
0

Have a look at OSS note 389936

Show 2 Share
10 |10000 characters needed characters left characters exceeded

But only if your SAP/R3 version is 4.0B or 4.6C (this corrective note is already 16 years old) Else just read FM CO_ZV_CONSISTENCY_CHECK documentation and exception list.

1

We are using ECC 6.0, will go thru FM CO_ZV_CONSISTENCY_CHECK documentation and try to find any clue.

Thank you so much!

Regards,

Kumar

0