Skip to Content
avatar image
Former Member

saprouter doesn't start as service

Hello!

We faced with some troubles with our system (based on MSWin2003).

Our saprouter worked correct before using SNC connect to SAP.

Now, when we try to start saprouter via services.msc we get

error 1053 the service did not respond to the start or control request in a timely fashion

On MS site I have found article where describes the same problem with other service. Article told us that the problem in Framework.NET and recommends to upgrade it. Here is the link [NET Framework|http://support.microsoft.com/kb/839174]

Now saprouter works only in console mode.

d:\saprouter\saprouter.exe -r -K "p:CN=<our_servername>, OU=<our_cust_numb>, OU=SAProuter, O=SAP, C=DE"

With the same string in services saprouter doesn't work.

Thanks

Artem

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Mar 05, 2008 at 02:20 PM

    Artem,

    If I am not mistaken, the router should be started like

    d:\saprouter\saprouter.exe service -r <routtab-file-location> -K "CN=<our_servername>, OU=<our_cust_numb>, OU=SAProuter, O=SAP, C=DE"

    I have got it to work the above mentioned way. Try and let me know.

    thanks

    BMG

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      You install it as a service with ntscmgr for exemple.

      You change the logon user if you use SNC as Joe told you.

      You can choose to select "Automatic" as startup type if you like.

      Then you start the service.

      Regards,

      Olivier

  • avatar image
    Former Member
    Mar 05, 2008 at 02:48 PM

    Hi,

    To run saprouter as a windows service, you need the parameter "service" on the command line.

    Exemple seen from properties of one of our saprouter service :

    C:\usr\sap\SAPRouter\saprouter.exe service -r -R C:\usr\sap\SAPRouter\routtab

    Regards,

    Olivier

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi there,

      I had this problem and I solved it with your suggestion. Thank you very much.

      Best regards

      Nuno Raposo

  • avatar image
    Former Member
    Mar 05, 2008 at 03:47 PM

    One thing to check is to make sure this is running under the [sid]adm account. SNC won't work if the service is setup to run under the Administrator account.

    Hope that helps.

    J. Haynes

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 06, 2008 at 08:02 AM

    Hi Artem,

    Login using <sidadm> and then use the following command to install the router aas service in windows:

    ntscmgr install SAProuter -b <path like usr/sap/saprouter>\saprouter.exe -p "service -r <parameters>"

    Hope this helps!!!!

    Reward points if helpfull.

    Regards,

    Vamshi.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Artem,

      1st - when I start saprouter error 1053 occured: the service did not respond to the start or control request in a timely fashion. It must start by sidadm user.

      This seems that the user you are trying to start the router does not have the permissions at os level so user <sidadm> to start the router.

      2nd - you told me that I can use "service" parameter in command line. And I ask you: Will saprouter appear in services.msc as service or will it be work in "background" without appear in services.msc?

      Normally we start the router at command prompt by using the command saprouter -r <parameters> at the os level in the folder usr/sap/saprouter

      But as you want to make it as windows service you have to first install it as a service then only you can use it as a service.Simply typing service in the command can not make the router to be installed as service.If you want to install this as a service then you have to execute the command which i have posted in my previous post.

      Hope this helps!!!

      Reward points if helpfull.

      Regards,

      Vamshi.

  • Mar 19, 2008 at 08:22 AM

    Hi Artem,

    I had the same issue here.

    If you look at the properties of the saprouter service in service manager, you'll notice that the p:CN=<our_servername>, OU=<our_cust_numb>, OU=SAProuter, O=SAP, C=DE" part is clipped at p:CN=<our_servername>,

    What I did to fix this, is delete the spaces.

    So do

    ntscmgr remove saprouter

    ntscmgr install saprouter -b d:\saprouter\saprouter.exe -p "service -r -K "p:CN=<our_servername>,OU=<our_cust_numb>,OU=SAProuter,O=SAP,C=DE""

    Then try start the service.

    Let me know if that worked.

    Paul.

    Add comment
    10|10000 characters needed characters exceeded