Skip to Content
avatar image
Former Member

500 Connection timed out

Hello,

I receive a 500 Connection timed out error.

I know that there are some threads to this error but I can´t find a solution for us.

This is the error description:

Error: -5

Version: 7000

Component: ICM

Date/Time: Tue Mar 04 07:02:38 2008

Module: icxxthr.c

Line: 2698

Server: crmprod_CRP_01

Error Tag: {-}

Detail: Connection to partner timed out after 60s

Now I have found in this forum some information about the parameters icm/keep_alive_timeout, icm/conn_timeout and icm/server_port_*

Our settings for this parameters are:

icm/server_port_0 = PROT=HTTP,PORT=8001

icm/server_port_1 = PROT=SMTP,PORT=25

icm/keep_alive_timeout (sec.) = 600

icm/conn_timeout (msec.) = 5000

Can someone please explain me which parameters occurs this error and which parameters I can change that the connection time is longer than 60 seconds?

Where can I change the parameters?

Regards

Philipp

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

10 Answers

  • Best Answer
    Mar 04, 2008 at 07:57 AM

    Hi,

    This is caused by the processing timeout, increase the PROCTIMEOUT

    ....

    icm/server_port_ < n > = ...,PROCTIMEOUT=< s >.

    should resolve the problem.

    Cheers,

    Aaron

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Phillip,

      run transaction SXMB_ADM.........Click integration engine configuration........choose parameter RUNTIME.......click on the edit button above...................click on new entry button.......choose category - RUNTIME, parameter - HTTP_TIMEOUT, current value - 600 and then save it.............

      re-run your scanario...........now your Connection timed out error should be removed.

      Regards,

      Rajeev Gupta

  • Mar 04, 2008 at 08:14 AM

    Hi,

    Parameter icm/conn_timeout

    icm/conn_timeout is used to set the timeout when setting up the connection. If the timeout is exceeded, an error page is generally displayed with the information "404 Resource not found" "Partner not reached".

    Therefore, exceeding the icm/conn_timeout does not lead to a "500 Connection timed out" error message.

    Processing timeout and keepalive timeout

    The icm/keep_alive_timeout and icm/server_port_< n > parameters define the keepalive timeout and the processing timeout.

    ICM distinguishes between these two types of timeout.

    The processing timeout is the timeout between the HTTP request being issued and the HTTP response being received.

    If the ICM is used as a server for the relevant HTTP request (in other words, when it forwards an incoming request to the SAP Web Application Server), the processing timeout is the time that the ICM will wait until a response is received from the SAP Web Application Server (ABAP or J2EE). This interval may be exceeded with long-running applications in ABAP or the J2EE engine. If the processing timeouts are exceeded, the ICM sends the client an HTTP response with the error code "500 Connection timed out".

    If the ICM serves as a client for the relevant HTTP request (that is, when it forwards outgoing requests from the SAP Web Application Server), the processing timeout is the time that the ICM waits until a response is received from the network. This interval may also be exceeded in the case of long-running applications in the network.

    The keepalive timeout specifies how long the network should remain open after a request has been processed successfully so that the TCP/IP connection does not have to be reestablished if additional requests are received.

    When you set the keepalive timeout, this does not normally lead to timeout errors. You should set the keepalive timeout high enough that the connection does not have to be reestablished for requests that are sent within a short time of each other, but low enough that the number of unused open TCP/IP connections is not unnecessarily high. Exceeding the Keepalive timeout should never cause an error.

    Configuration of the ICM parameters for the processing timeout and the keepalive timeout

    For the ICM, the parameters mentioned here are in the instance profile.

    The processing timeout is set for individual services with the following parameter:

    icm/server_port_ < n > = ...,PROCTIMEOUT=< s >.

    The keepalive timeout can be set globally for all services of the ICM with the parameter icm/keepalive_timeout.

    You can also set it for individual services by using the following parameter:

    icm/server_port_ < n > = ...,TIMEOUT=< s >.

    If you set this parameter, it overwrites parameter icm/keepalive_timeout for the specified service.

    Even if the ICM serves as client for a request, the TIMEOUT and PROCTIMEOUT parameters of icm/server_port_ < n > control the timeouts for the relevant protocol, provided that you have set TIMEOUT or PROCTIMEOUT.

    If you have not set the PROCTIMEOUT parameter, TIMEOUT (or icm/keepalive_timeout) defines both the processing timeout and the keepalive timeout. Also, as of release 6.40, the keepalive timeout is limited to a maximum of 30 seconds.

    In a system where the default timeout settings of 30 seconds for the keepalive timeout and the processing timeout are not sufficient because of long-running applications, we recommend that you set the TIMEOUT and PROCTIMEOUT parameters for the relevant services so that you can configure them independently of each other. In addition, we recommend that you do not set the TIMEOUT value higher than necessary, for example, to the usual default value of 30 seconds.

    We recommend, for example, the following settings:

    icm/server_port_0 = PROT=HTTP,PORT=1080,TIMEOUT=30,PROCTIMEOUT=600

    to allow a maximum processing time of 10 minutes.

    I hope this info will help you to sort out the error you getting.

    Regards

    Aashish Sinha

    PS : reward points if helpful

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 04, 2008 at 06:50 AM

    Hi,

    Check with this

    https://www.sdn.sap.com/irj/sdn/weblogs?blog=/pub/wlg/3802

    REgards

    Seshagiri

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello,

      the blog from Seshagiri doesn´t help me because the description is about other errors.

      The help file from Prateek is also not helpful. The icm/conn_timeout is at the default value of 5 seconds. I get an error messag that the connection timed out after 60 seconds.

      Regards

      Philipp

  • Mar 04, 2008 at 06:52 AM
    Add comment
    10|10000 characters needed characters exceeded

  • Mar 04, 2008 at 06:59 AM

    under that ICM HTTP CONNECTION RFC check that option

    NO CONNECTION TIME OUT.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Nissar

      Could you explain where can we getb this option as i don't see any RFC in SM59 for the same . I am getting this error in Solution manager 4.0 while creating project through Tcode ai_sps .

      Error Code :

      500 Connection timed out

      -

      -


      Error: -5

      Version: 7000

      Component: ICM

      Date/Time: Thu Apr 03 16:48:43 2008

      Module: icxxthr.c

      Line: 2646

      Server: proisap01_SOL_01

      Error Tag: {-}

      Detail: Connection to partner timed out after 60s

      © 2001-2005, SAP AG

  • avatar image
    Former Member
    Mar 18, 2008 at 06:22 AM

    hi,

    for this session timeout error,

    you can try this one.This way you can increase your session time as per your need.

    go to server.

    path for visual admin generally,

    my computer - user - sap - sc...-j2ee -admin -got.bat

    then,

    admin->go.bat.connect->server->services->web connector ->change time->save->restart that process only.

    i hope this will solve your error.

    Thanks,

    Nutan.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 18, 2008 at 06:39 AM

    hi

    you can try increasing the HTTP_TIMEOUT of the Integration Engine:

    a) go to TCODE - SXMB_ADM

    b) Integration Engine Configuration

    c) Change specific configuration

    d) Increase the HTTP_TIMEOUT parameter value - this value depends on your specific needs

    the picture below is only for demonstration purposes and it does not present the recommended value

    note:reward points if solution found helpfull.....

    regards

    chandrakanth.k

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 17, 2009 at 09:37 AM

    Hi Philipp,

    do you by any chance still know which parameter or which setting solved your "500 connection timeout"-problem?

    Thanks a lot in advance.

    Best regards,

    Henning

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 25, 2010 at 01:34 PM

    ALL, Aashish Sinha is right, i runed into same problem, and following Aashish Sinha 's solution, i added proctimeout=600, then restart the instance, it works fine.

    Roger

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 05, 2012 at 02:21 PM

    In case someone else comes to this...

    I had to change this PROCTIMEOUT value under sapwebdisp.pfl in the profile of sapwebdispatcher and after that only restarted the sapwebdisp and all good.

    Add comment
    10|10000 characters needed characters exceeded