Skip to Content
avatar image
Former Member

Why the application is running with Build errors?

Hi Friends,

When i am Building my Application there are a few Build errors.

But when i am Deploying and Running my Application its working.I am able to make changes and work on my Application.

How is this possible?

What might be the problem?

Does this effect my Application in future?

Please let me know.

Thanks and regards,

Chandrashekar.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Feb 28, 2008 at 05:17 AM

    Hi,

    Just go to your task view and check, it might be possible that errors are not related to your project but to some other project that are open.

    Regards,

    Murtuza

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      What kind of erros it is showing.First make sure that your project name is appearing under Resource tab in Problems.

      Regards,

      Sudhir

  • avatar image
    Former Member
    Feb 28, 2008 at 09:00 AM

    hai chandrasekhar,

    usually you ll be able to deploy your application inspite of build error when the ui elements placed in view have same name.so check them if any ui elemnts like group,transparent container,inputfield ....carries the same name.you ll be able to deploy but when you navigate to that view wch carries duplicate ui elements ull be getting the error in details wch ll stop you from navigating further.

    Thanks n Regards

    Sharanya.R

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 07, 2008 at 10:22 AM

    Hi,

    You will be able to deploya an application with the build error in that project only if those build errors are not present in the default interface view used for that application.

    Error msg will come if any of the view inside that project is having error whether that is been used in applicaiton or not.

    hope that answers your question.

    Regards

    Deepak

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 07, 2008 at 10:27 AM

    Hi ...

    Sometimes you may have the jar files missing at build time i.e you may have not added jar files to the build path.. or you have given the wrong path where its not able to find it...

    But when you run the application i.e during runtime it refers to the jar files present on the on the server side...

    Regards

    Akshaya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 21, 2008 at 01:09 PM

    NetWeaver seams to build and then deploy. If the build fails it deploys the old version. This is a little confusing...

    Add comment
    10|10000 characters needed characters exceeded