Skip to Content
0

Error when opening RFC connection

Nov 23, 2017 at 08:27 AM

61

avatar image
Former Member

Hello folks,


We're recently confronted with a situation when we are setting up the Integrated Configuration iDoc Configuration. Everything's fine and dandy on the PI side, inboundRA configured and all. The RFC connection done on the ERP side also has the connection test successful.



What is tested and working:


1) inboundRA and all Java stack RFC connections have been configured and successfully tested


2) The WE20, WE21, SM59 configuration in the sending ERP system have been configured and successfully tested (see attachment)

follow-the-white-rabbit.png


3) SEC_INFO and REG_INFO files have been adjusted by the Basis team to facilitate this connection already


4) The inboundRA configuration results in the program instances being registered in the gateway in SMGW


5) The configuration in PI looks good, we got a generic sender iDoc channel, an integrated Config object and then a receiver channel that's working for other scenarios.

What our problem is: when testing from WE19 the iDoc, we sometimes (emphasis on sometimes) get the error seen in the attached image.

sm58-screenshot.png

Some other messages, I've seen them executing in SM58 (if I'm quick enough) and then being successfully processed by PI.

I've also tried setting the RFC connection as slow RFC and there was no progress; still, some but not all the test messages get stuck in SM58 and some are processed successfully in PI and they're getting delivered to the receiver system.

Please let me know if you got any ideas on how to get to the bottom of this.


Best regards,


George

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Priyanka Anagani Nov 24, 2017 at 06:29 AM
0

Hi George,

You mentioned that only sometimes Idocs are getting stuck in SM58. Are you able to reprocess the SM58 failure after sometime?

If you are able to reprocess means, it could be a connectivity issue which need to be investigated taking help from Basis & network teams. Collecting the RFC trace when the issue is happening would help in identifying if there is any isues with connectivity.

If you are unable to reprocess even after multiple retries, then when you reprocess from SM58, you'll get an error in Idoc sender communication channel & log in NWA logviewer in PI. Check the log and then troubleshoot accordingly.

--Priyanka

Share
10 |10000 characters needed characters left characters exceeded