Skip to Content
0

When exporting as .xlsx from crystal, columns and rows are compressed, How do we fix this?

Nov 22, 2017 at 07:06 PM

99

avatar image
Former Member

When exporting as .xlsx from crystal, (File/Export as Microsoft Excel Workbook Data-only) columns and rows are all compressed. We have tried to set different options and it seems to ignore column width settings (column width based on objects in the Group Header #1); the checkboxes 'maintain column alignment' and 'maintain relative object position'.

We are on Crystal 2016 Support Pack 2 V 14.2.2.1975

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Don Williams
Nov 22, 2017 at 09:40 PM
0

Hi Tracey,

Open the report in CR Designer and click on File, Export and then Report Export Options. Select Excel Workbook and now you have the option to set Constant Column Width, select a number that fits all data in any field.

Save the report, when exporting it will use those values.

Don

Share
10 |10000 characters needed characters left characters exceeded
Ido Millet Nov 22, 2017 at 08:41 PM
0

At least one of the 3rd-party Crystal Reports Desktop Schedulers listed here provides options to auto-fit column widths (with optional maximum column width argument).

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 28, 2017 at 06:19 PM
0

Thank you Don! Saving the .xlsx with constant column width worked.

I also have to manually set the row heighth to 20 because these information is compressed. Is there any way that we can set the row heighth?

Best regards, Tracey

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 28, 2017 at 06:53 PM
0

In order to make the row height not compressed, set each field's height to .583. This will work for .xlsx, but when exporting to .xls it makes the row height look a lot bigger.

Share
10 |10000 characters needed characters left characters exceeded