Skip to Content

Seeburger : The Mapping you are trying to load was not found!

Dear Experts,

Need help .

I wanted to create mapping file for D01b orders for edi seeburger.

I used seeburger tool version 2,2.

I made myself admin in the tool installed on my laptop by making entry CmdLnArgX=-ProjectAdmin

Imported the bicmd file of Activemapping, imported xml of D01b and ran generator mapping which created XML and mappings for E2X and X2E.

I did SCA/SDA version assignment and made it 00.

Selected the project and clicked on create deploy file.

It complied all the files and created a mapping_user00.sca and sda file.

When basis person deployed this sca file , all the existing bic mappings are gone and the one I created is also not visible.

What am I missing here?

It says :

DESCRIPTION: BICMapping: FATAL ERROR: The Mapping you are trying to load was not found! Last error: BICMapping runMapping() The mapping: Oce_E2X_ORDERS_UN_D01B you are trying to load cannot be found in the classpath! Maybe you forgot to deploy the mapping! DESCRIPTION: BICMapping Error: The mapping [not specified] you are trying to load cannot be found in the right path! Maybe you forgot to compile or to activate the mapping!

Please suggest something.

Thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Former Member

    Hi Dilip,

    The name of the user generated sda' should be "Mappings_user00" , not "mapping_user00".

    You can look for available mapping under the Seeberger workbench link http://host:port/seeburger/index.html ----> System Status -->BIC Mappings.

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 15 at 10:04 AM

    Thanks Jitendra for your inputs.

    The problem was , I was using latest version of BIC mapper tool , whereas the SCA files deployed in PI and XI were from older versions of BIC MD.

    Point to note here is that , it matters a lot to choose the correct version of BIC mapper tool.

    So when I had the correct version I then faced another issue that the older version needed older windows OS in my laptop to run that.

    But I overcome that by changing the compatibility mode of BIC mapper and run it in older OS in my laptop.

    https://www.windowscentral.com/how-make-old-desktop-apps-run-again-windows-10

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 06, 2017 at 01:27 PM

    Hi Dilip,

    Have you moved or copied the corresponding mapping the mapping project which is used for SDA/SCA creation?

    Once done select this project and select "Create Deploy" file -> In the next screen, it will show you the list of mappings. Make sure it have all the mapping which are already there in PI server (including your new mapping) -> then generate the sda file.

    You can open the generated file using any unzip tool and cross check if this have all the required mappings or not.

    Check if below links helps you in any way.

    https://archive.sap.com/discussions/thread/1417716

    Regards

    Jitender

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Jitendra for your inputs.

      The problem was , I was using latest version of BIC mapper tool , whereas the SCA files deployed in PI and XI were from older versions of BIC MD.

      Point to note here is that , it matters a lot to choose the correct version of BIC mapper tool.

      So when I had the correct version I then faced another issue that the older version needed older windows OS in my laptop to run that.

      But I overcome that by changing the compatibility mode of BIC mapper and run it in older OS in my laptop.

      https://www.windowscentral.com/how-make-old-desktop-apps-run-again-windows-10