Skip to Content

​JSF1029 error while using neo-javaee6-wp-api - 2.122.6

Hello Experts,

I have a simple Servlet application implementing a doGet and using only neo-javaee6-wp-api:2.122.6. No other dependencies. While running the application from SCP the following error is being generated.

JSF1029: The specified Injection Provider implementation 'org.eclipse.virgo.web.enterprise.jsf.support.VirgoJsfInjectionProvider' does not implement the InjectionProvider interface.

If I use "javax.servlet-api:3.1.0" then I don't get any error. I need the neo API because I want to further expand the servlet with some SCP Destination functions.

I have already look at the thread https://archive.sap.com/discussions/thread/3383386 but this doesn't seem to be my case.

Could you please guide

Thank you,

Thanu

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jan 10 at 07:17 PM

    Hi Thanu,

    Check the answers on this thread. Apparently you are relying on Eclipse WTP to create the Dynamic Web Project without using Maven - which in my option makes everything way too confusing to manage the APIs used. Avoid getting crazy and start using Maven to handle your project dependencies and make it update the WTP settings accordingly.

    Regards,
    Ivan

    Add comment
    10|10000 characters needed characters exceeded