Skip to Content
0

Blank space printing before each page in Crystal Reports.

Nov 27, 2017 at 08:53 AM

101

avatar image
Former Member

Hi,

We are facing a serious issue while printing from our POS application in crystal reports. Previously we were using Crystal Reports Runtime version 10.5.37 and the printing was alright with all POS printers available. Now we have migrated to Crystal Runtime version 13.0.20 and after that most of the receipt printers are printing a blank space before printing the document. We are using Crystal Reports 2011. Please help us since this has been a serious concern for all our clients.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Don Williams
Nov 27, 2017 at 07:23 PM
0

As of CR 2008 SP 3 all printing is done differently, you can set orientation by section now.

Do they print using CR Designer correctly?

What Printer are you using?

Are the paper sizes using custom sizes or defaults?

Don't use No Printer in the Report and enable Dissociate.

On the download WIKI there is a link to a printer test app I wrote, try it to see if it works.

Don

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Don,

Please see the following points which would help us to analyse the issue better:

1.) Using CR Designer the print is coming correctly.

2.) As of now, the problem exists in the following printers:

a.) Citizen CT-S310II

b.) Star BSC 310.

c.) TVS 3200.

We are having no issues with all printers of EPSON model and the print is perfectly fine while using this printer.

3.) If we go with the Citizen printer, the paper size is not set as Custom Size, the size set is "Receipt 80 x 3276 mm 48c".

4.) "No Printer" option is unchecked but we have not enabled "Dissociate", although we have tested by enabling Dissociate and set the paper size manually to "80 x 3276" and the result is still the same.

5.) We have not yet tested the printer test app, can you share the link so that we can perform a test print.

We have also installed the latest printer driver from Citizen's website but the issue still persists.

Please help.

Suvradip

0
Don Williams
Nov 29, 2017 at 05:47 PM
0

Links are on the download WIKI page:

https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

I tried installing the Citizen driver and it worked but without the printer I can't test it.

I do have a Zebra and Argox label printer and they do work as well.

See if there is an option to not do a Form Feed before printing in those Printer Server settings.

Don

Share
10 |10000 characters needed characters left characters exceeded