Skip to Content
avatar image
Former Member

How change the encoding of xsd?

Hi.

I have an xsd file that has as encoding the ISO-8859-7. When importing it into XI the encoding is changed to ISO-8859-1.

To be more specific the

<?xml version="1.0" encoding="ISO-8859-7"?>

is converted to

<?xml version="1.0" encoding="ISO-8859-1"?>

How can I change this one?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Feb 15, 2008 at 12:00 PM

    Why is it nessecary to have ISO-8859-7 for you?

    Do have any special characters in the data type definition?

    Otherwise it should not be an issue, as this is not related to the content of the XI payload.

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      You are right! I had the impression that encoding in .xsd had to do with the payload. But was wrong!

      Thanks for pointing that out!

  • avatar image
    Former Member
    Feb 15, 2008 at 12:04 PM

    Hi,

    You can use XML Anonymizer Module.

    This module has a parameter called anonymizer.encoding

    you can use this to change the encoding of your XML.

    Refer to SAP note Note 880173 for more details.

    You can also check the blog

    link: [https://www.sdn.sap.com/irj/sdn/weblogs?blog=/pub/wlg/5767] [original link is broken] [original link is broken] [original link is broken];

    Award points if found useful.

    Regards

    Abhishek

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 15, 2008 at 08:57 AM
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for the answer.

      In that thread is mentioned a problem with xml file and the namespace. My problem is in a xsd schema file and I can't see how I could apply the solution you propose in my case... Could you be more specific please?