Skip to Content
0

Crystal Reports Excel Field Names

Nov 22, 2017 at 05:38 PM

37

avatar image
Former Member

Hi,

I had a report which worked fine linking to Excel. It picked up the field names correctly e.g AccountNo.

When I went to run the report Crystal throws a dialogue box saying the field names are unmapped. Crystal is not seeing the field names in row 1 like it did before. Instead it is showing F1 F2 F3 etc.

I tried as a workaround mapping the fields without the names. E.g AccountNo to F1 but Crystal crashes.

Is there a setting to force Crystal to see the first Row as field names? I’m using the Crystal Excel DAO to connect to the file.

Thanks.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Vitaly Izmaylov
Nov 22, 2017 at 06:24 PM
0

Check the following registry:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Jet\4.0\Engines\Excel

there should be "FirstRowHasNames" set to 01
Share
10 |10000 characters needed characters left characters exceeded
Ido Millet Nov 22, 2017 at 06:00 PM
0
Share
10 |10000 characters needed characters left characters exceeded