Skip to Content
0

WDA debugging not working after upgrade to EHP8

Nov 22, 2017 at 03:03 PM

106

avatar image
Former Member

Hello Experts,

I am from the ABAP team.

I am not able to debug WDA from SE80/T-code with the ECC system after upgrade(EHP 8 SPS7 from ECC 6.0).

We have copied the data from Prod to our new system POC(Testing).

I have tried the below techniques,

1) T-code - SRDEBUG , to activate debugging
2) Activate debugging in SICF, it doesn't work in the system from T-code/SE80 but works from SICF when testing the service directly from SICF

3) Due to an SAP issue, all the non standard roles/authorizations values in table are not copied from Prod into POC system due to SUM2.0 SP00 issue. Note has been issued for this which will be done in the dev system but can this be an issue for not debugging in WDA ?

4) Note -> 1652108, I have gone through notes, the values are same as in the previous system too.

5) I have set the profile rdisp/tpda_for_ext = 1 in RZ10 too.

I am still unable to debug WDA after doing these.

Thanks,

Nikhil

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
avatar image
Former Member Nov 23, 2017 at 09:39 PM
1

Hello Guys,

You can check this

Note 2536431 - Debugging with user breakpoints no longer works(There is a work around note too but this didn't help)

But the solution is below,(Would require Basis help too)

The reason the debugging was working from SICF when tested was because it was using the correct WDA URL(correct server name)

In SE80/anywhere else when you test, the URL was different and referring to a Web dispatcher server of Production. This was set in the Production I guess.

So to remove this we had to configure ICM/HOST_NAME_FULL with the server name (But this too was correct/already present)

https://help.sap.com/viewer/0c333adb55cd4dbf8e92a5175703224c/7.5.9/en-US/483c5d3df7e771b9e10000000a421937.html

But since we knew the server in the URL of WDA was Web dispatcher of Production,

https://help.sap.com/saphelp_nw70/helpdata/en/42/d547ab30b6473ce10000000a114e5d/frameset.htm

The table HTTPURLLOC had the Web dispatcher production server configured, so once we change the server/port to the POC server(guess we can also delete the entry and the value is picked up from ICM/HOST_NAME_FULL), we were able to get the debugger and the correct URL's were generated on WDA in POC system

https://archive.sap.com/discussions/thread/3439388

Hope this is helpful to others who come across this scenario.

Thanks,

Nikhil

Share
10 |10000 characters needed characters left characters exceeded
Mike Pokraka Nov 22, 2017 at 09:04 PM
0

In your list you didn't include the simple way of debugging: setting a breakpoint in your code and testing the application from SE80.

Might also be worth trying from Eclipse.

Authorization may well be an issue. Try an auth trace or try with SAP_ALL to test this.

Show 5 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Mike,

Thanks for the reply,

Yes, I have tried setting a break-point statement in the code too , it doesn't trigger it. I have SAP_ALL authorization too.

Thanks,

Nikhil

0

If you go into SE80 settings, under debugging options, please make sure you don't have another user set for external debugging. Happened to me before - it will then only break for that user and not your own.

0
Former Member

Yes, I have checked it, It is set with my user id.

0

Sorry, can’t think of much else without actually looking at it directly.

Is your SAPGUI up to the latest patch/version? And did you try with Eclipse?

0
Former Member
Hello Mike,

Thanks for your time and help, Please find below the solution.

Regards,

Nikhil

0