Skip to Content
0

Crystal Reports 2013 not working with Windows 10 - Driver's SQLSetConnectAttr failed IM006

Nov 21, 2017 at 09:24 PM

224

avatar image
Former Member

We recently updated to Windows 10 using Crystal Reports 2013. Now we cannot open View or Edit Command when accessing the database expert. The error we get is: Logon Failed. Details: IM006: [Micosoft][ODBC Driver Manager] Driver's SQL SetConnectAttr failed.

Things we have tried so far:

  • running Crystal reports in System Administrator Mode
  • changing compatibility mode to Windows 7
  • verified that we are running SQL Server Native Client 11.0
  • running appwiz.cpl and turning on .net framework 3.5.1

SAP representative did not have any other options for us to try so she suggested we post our question here. Any help would be greatly appreciated.

Thanks.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Vitaly Izmaylov
Nov 21, 2017 at 09:29 PM
0

If it is Salesforce.com connection then you need to configure Proxy. KBA 1978931

Resolution:

  • To add the proxy setting to the Salesforce.com connection for Crystal Reports:
    1. Navigate to the location of CRConfig.xml file, which is located by default at:

      C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\java\
    2. Open the CRConfig.xml file in a text editor like Notepad.
    3. Add the following lines to the <SForce> section of the XML file, with your proxy settings:

<UseProxy>TRUE</UseProxy>
<ProxyAddress> Add the proxy name here </ProxyAddress>
<ProxyPort> Add the proxy port number here </ProxyPort>


Below is an example of how the xml file will look after adding the proxy setting for the Salesforce.com connection,
if the proxy name is: MyProxy, and the port number: 1234

<SForce>
<UseProxy>TRUE</UseProxy>
<ProxyAddress>MyProxy</ProxyAddress>
<ProxyPort>1234</ProxyPort>
<CacheRowSetSize>100</CacheRowSetSize>
<QueryBatchSize>2000</QueryBatchSize>
<SocketTimeout>600000</SocketTimeout>
<BatchLookupCacheJoinSize>200</BatchLookupCacheJoinSize>
</SForce>

Share
10 |10000 characters needed characters left characters exceeded
Brian Dong Nov 21, 2017 at 09:29 PM
0

Hi Michelle,

What version of SQL Server are you trying to connect to?

I'm assuming SQL Server Management Studio is able to connect fine.

Do you know if you can connect to SQL Server with another application like MS Access or Excel?

Crystal is 32 bit so you will need to install the 32 bit client for SQL Server on your machine as well.

Good luck,

Brian

Share
10 |10000 characters needed characters left characters exceeded
Don Williams
Nov 22, 2017 at 02:48 PM
0

Hi Michelle,

Why are you running CR in Compat mode?

Why are you turning on 3.5 framework?

If you create an OLE DB connection does that work?

Don

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 29 at 09:52 PM
0

I want to thank everyone for their input. We actually had to reinstall SAP Crystal 2013, BI Platform, and the ODBC driver. I believe it was probably just the ODBC driver that I was missing due to a Microsoft Office Upgrade to 2016. I have a colleague who has the same issue due to upgrade to Windows 10.

Share
10 |10000 characters needed characters left characters exceeded