Skip to Content
0

FCC - csv to csv - comma in field

Nov 21, 2017 at 04:19 PM

56

avatar image

1.png2.png3.pngI've got a CSV to CSV scenario, i need to do some manipulation on the data in mapping.

The source csv comes from Sap ecc, one of the fields that causes me issues is description and occasionally has additional comma's in it causing fcc issues.

I've done a bit of reading around this and have used the fieldSeperator=, and enclosureSign=" as advised in other posts. The file gets read but comes out in the receiver as a 1kb file so isnt fully getting read / converted by sap pi. Image 1 shows the file getting read, 2 is the fcc, 3 is the resulting file.

Your help is gratefully received.

1.png (54.6 kB)
2.png (30.4 kB)
3.png (50.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

George Applegate Nov 23, 2017 at 11:20 AM
0

Any ideas experts?

Share
10 |10000 characters needed characters left characters exceeded
Evgeniy Kolmakov Nov 23, 2017 at 11:52 AM
0

Hi George!

I guess the settings you've set wouldn't work.

Is far as I understand, "enclosureSign" parameter determines the boundaries within which the content should stay untouched. For example, in case of row contents like:

"field1","field2","fi,eld3"

your settings would work as expected.

In other cases this option is useless, I guess. Just ask yourself: how should FCC distinguish comma acting like a separator from the same comma, which is the part of field content.

So I think the decision might be to use fixed field lengths for source file or to use some "enclosure sign" for field content, for example ~field~ or "field".

Regards, Evgeniy.

Share
10 |10000 characters needed characters left characters exceeded