Skip to Content
0

Fiori Application : No items are currently available

Nov 21, 2017 at 11:21 AM

163

avatar image

I am Posting this request after searching all the posts. please provide some input where and what i am doing wrong.

We have installed and deployed SAP Fiori on SAP ECC6.

I have been tying to get the SD Applications (i) Creates Sales Orders, (ii) Change Sales Orders, (iii) Track Sales Orders etc. but in Fiori tile, none of the entries are reflecting / remains empty.

I have followed all the Fiori Instruction steps related to SAP SD configuration.

My user id has been assigned to an Employee Number and This employee number has been assigned through the partner functions to customers.

Also, configure SIMGH in the backend system for above applications

We have Defined Configuration Parameters for Sales Order Create App (Please refer file the attached screen shot). for DOCTYPE in place of ZRMS i have tried TA also.

After doing all this configure setting still Fiori Tiles remain empty and I am getting a message " No Items are currently available"(Refer the attached Screen shot)

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Mohan P Nov 30, 2017 at 10:57 AM
0

My Problem is resolved, problem is in my Partner function, there are two partner functions with same naming convention. i removed one after that fiori tile are working fine.

Share
10 |10000 characters needed characters left characters exceeded
Jyoti Prakash
Nov 21, 2017 at 12:09 PM
0

In ECC, can you check whether you have sales doc type ZRMS.

To do that either check the same in TCode VOV8 or refer Table VBAK, and check whether you have VBAK-AUART = ZRMS related records. Even you can use table VBAK to understand, what all sales doc types are in use in ECC system.

Thanks,
JP

Show 7 Share
10 |10000 characters needed characters left characters exceeded

Hi Former Member,

Thanks for reply,

Yes we have sales doc type ZRMS

0

Why are you using Partner as Ship-to Party(SH/WE)?

Ideally, for Sales Order, it should be driven through Sold-to Party(SP/AG).

0

Dear Former Member,

Yes, you are correct.

But i have followed the SAP Fiori 1.0 for SAP ERP link where they have given configuration steps for App Implementation: Create Sales Order. whit the help of this link i have configured SIMGH settings. I have also assigned and tried both Ship-to Party(SH/WE) and Sold-to Party(SP/AG) in SIMGH but still in Fiori Tile nothing is reflecting.

I am inserting my partner function screen shots, please look in to it and suggest me if i am doing any thing wrong.

0

Then, in that case, debugging console(F12) check the service status, whether that is connected or not.

0

Dear Former Member,

Thanks once again for instant reply,

As you suggested i have done F12 in console after that i am getting these error. please look into these and suggest me for further action.

1) 2017-11-22 15:34:50 Failed to update data via service /sap/opu/odata/sap/SRA021_SRV/Summary: HTTP request failed - 500 Internal Server Error - sap.ushell.components.tiles.applauncherdynamic.DynamicTile

2) 2017-11-22 15:35:05 The following problem occurred: HTTP request failed400,Bad Request,{"error":{"code":"SRA017_SO_MSG/102","message":{"lang":"en","value":"No customer found for this user. Map using the business partner function."},"innererror":{"transactionid":"59F6F529A2ED0940E10080000A650416","timestamp":"","Error_Resolution":{"SAP_Transaction":"","SAP_Note":"See SAP Note 1797736 for error analysis (https://service.sap.com/sap/support/notes/1797736)"},"errordetails":[{"code":"SRA017_SO_MSG/102","message":"No customer found for this user. Map using the business partner function.","propertyref":"","severity":"error","target":""}]}}} -

0

I hope you understand HTTP request failed 400/500 meaning and cause.

Did you search for your error msg in SAP Community?
Say, https://www.google.co.in/search?q=Failed+to+update+data+via+service+/sap/opu/odata/sap/SRA021_SRV/Summary:+HTTP+request+failed+-+500+Internal+Server+Error+-+sap.ushell.components.tiles.applauncherdynamic.DynamicTile+site:archive.sap.com&safe=active&sa=X&ved=0ahUKEwiE5LechdLXAhUSJ-wKHdf8DigQrQIIMSgEMAA&biw=1680&bih=919

Did you refer SAP Note 1797736 mentioned in the error?

Did you look at the Gateway System Log?

0

Hi Former Member

I have already given above details to our team to look in to it, before that i have also searched related to this error but no luck. i have checked SICF where data is properly activated.

Is this because some Configuration Missing at back end? I have again re checked my SIMGH and PAL1 further assigned it to customer master partner.

Thanks

0