Skip to Content

Fiori Elements Overview Page Entity Set missing when creating card

Nov 21, 2017 at 05:00 PM


avatar image


I'm creating an Overview App, I have built a number of Entity Sets to support the various cards in my App. One in particular, which is to support and analytical card, doesn't show up in the list of available entity sets when you create the card using the card wizard.

Has anyone ever come across this?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Prasita Prabhakaran
Nov 24, 2017 at 04:21 AM

This is not a known issue as of now. Checking the metadata may be helpful.

10 |10000 characters needed characters left characters exceeded
Neil Ward Dec 15, 2017 at 09:31 AM

Ok so I kinda figured out what the problem was ... just in case this helps anyone.

I created my gateway project using a reference to CDS views (exposure via SADL) the entity which wasn't visible was one I added to the gateway project after it's initial creation. in other words... I created the GW project initially it had 5 entity sets based on CDS views... I then created the app and added the cards for those entities.

Then I wanted to add another card, so I built another CDS view and added it to the gateway project. it wouldn't show up in WebIDE when creating the card. However when I created a new gateway project and added all the views, including the new one... it suddenly showed up.

So perhaps there is a bug in the gateway tool?

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Or it is a cache issue ;)


I emptied the browser cache, are there any server side caches that could be emptied?

Felipe de Mello Rodrigues Dec 15, 2017 at 02:54 AM

Hi Neil,

Can you please share the card configuration from your manifest.json, the annotation.xml and metadata.xml file?

Without these details is really difficult to define the cause of the problem, but try to review the following items in your application:

  1. Review if your OData service and Entity Set consumption are working fine;
  2. Check if you declared at least one UI.Chart annotation for this Entity Set because analytical cards are not based in UI.LineItem annotations;
  3. Look the console log and check for possible abnormalities.



10 |10000 characters needed characters left characters exceeded