Skip to Content
0

Archiving asset accounting - Difference between testrun and productive run (both in test system)

Nov 22, 2017 at 11:12 AM

64

avatar image

Hello all,

I'm searching for someone with experience in archiving asset accounting.

Right now we are testing the archiving via AM_ASSET / AM_STEUER, it works well. But we wonder about some "not archived" assets.

I found documents in SCN wiki, SAP notes and help.sap.com and tried to read (and understand) all of them. More or less archiving checks retention time in customizing plus deactivation date (and some special processes like assets under construction...)

I took one example out of table ANLA which should be possible to be archived. When I enter the asset in the test mode (radio button "test run without archive file") and add this one asset into the variant it will give me as result that 1 asset is valid for archiving.

But when I start with the productive variant (radio button "update run" --> additional window for asset selection disappears, because this is only available for test run) it will select 0 (zero) assets for archiving.

My question is: Is there another check which I don't know? Why is there a difference in logic for "update run" and "test run without archive file"? I would except the same result from test run and productive run (in the same system, just difference of the radio button).

It would be great to get some inputs from you (maybe someone had similar issues???).

Thank you in advance.

Regards

Harald

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Jürgen L
Nov 22, 2017 at 01:02 PM
0

When you did the test run, had you also entered the company code, or only the asset number?

If only the asset number, then try it again by adding the company code as well.

Had you checked the job log and the spool file? did you run the archiving with detailed log?

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hello Jürgen,

thanks for answering.

Company code was filled for this variant (and for testing variant additional the asset number), I can see this in the log.

Are you sure there is a detailled log for object AM_ASSET? I know this flag for other objects, but here the variant doesn't offer to create detailled log. I just get some basic informations (quantities to be archived more or less...).

Regards
harald

0

I have 3 options for detail log and 3 for Log output in my variant.

am-asset.png (28.5 kB)
0

Hello Jürgen,

sorry for not answering, but had to investigate things before I reply.

I'm really confused now, because

1) I don't have these options in my variant screen

2) basis colleagues told me there is nothing to activate to get this (and there is no documentation from SAP side on this topic)

Attached please see a screenshot how it looks in our system. To be sure (because there is no header in your screenshot... this variant definition from your screenshot is from report RAARCH01?). We use ERP 6.0 EHP7 right now.

I appreciate your help, but maybe it is a better idea to create an incident to SAP. Not because of missing options in variant (this seems to be a consulting issue, I'm not an expert on this topic...), my main problem is still the different results from test mode to productive mode.

Thanks in advance.

Regards

Harald

0
Jürgen L
Nov 30, 2017 at 11:12 AM
0

My archiving always starts with transaction SARA.

I enter my archiving object and then define the the variant for the write job.

My screenshot is from AM_ASSET archiving object

your screenshot is specific to AM_STEUER .

see https://help.sap.com/saphelp_erp60_sp/helpdata/en/d2/55d7531a4d424de10000000a174cb4/frameset.htm

Share
10 |10000 characters needed characters left characters exceeded
Harald Leissl Dec 04, 2017 at 01:26 PM
0

Hello Jürgen,

my screenshot is AM_ASSET as well ;) But maybe I found the difference in our system...

It is correct that your screenshot shows variant for AM_ASSET. But my screenshot as well, I didn't mix up objects AM_ASSET and AM_STEUER. The system takes always the reports entered in AOBJ. If I search there for AM_ASSET I see

- write --> RAARCH01

- delete --> RAARCH02

- reload --> RAARCH03

I believe you have a different entry at "write", maybe AM_ASSET_WRI??? I found this report AM_ASSET_WRI in some "non-SAP-documentation", and this fits exactly to your screenshot! I can't find any SAP documentation about this (new) report. Maybe it will be inserted in some newer SAP version...

Right now I am not sure why there are 2 different reports and why we use the old (bad?) one... I will make some tests about it :) If it works without any advantage I will switch AOBJ-entry to the new report and hope I will get better logs :)

Thanks a lot for your inputs!

Regards

harald

Show 1 Share
10 |10000 characters needed characters left characters exceeded

yes I have AM_ASSET_WRI in my main system, but in other systems I also see RAARCH01 . I have no idea when this changed. I just searched SAP market place with AM_ASSET_WRI and found an Excel sheet about ILM enabled archiving write objects where it is listed.

0
Harald Leissl Dec 05, 2017 at 09:50 AM
0

Hello Jürgen,

here my summary:

- detailled log is possible only with report AM_ASSET_WRI, I changed tests to this report

- situation still remains the same, test flag finds one asset to be archived, productive flag (without any changes in other fields!) doesn't find anything

- I can't see any reason in the log, it just doesn't find assets to be archived in productive run

"No log was generated" seems to happen if nothing is found (I'm really sure that i marked "detailled log").

All my actions were in the quality system... so I hope that situation changes in productive system. If I find out why both modes give different results (self investigation or SAP-support) I will update this conversation. Right now it is still not clear for me. But I have to go on with archiving, makes no sense to stop it because of 0,1 % non-describable system behaviour :)

Many thanks for your inputs!!! I really appreciate this!!!

Regards

Harald


log-test.jpg (166.3 kB)
log-prod.jpg (188.8 kB)
Share
10 |10000 characters needed characters left characters exceeded