Skip to Content
avatar image
Former Member

I have updated Axis adapter jar file compiled SDA and deployed it via NWDS, SOAP could not start

There was a need to update Axis adapter in SAP PI 7.31 SP

1000.7.31.14.4.20160123010700 (Dual Stack) due xmlsec jar issue. I did that with NWDS and it was successful. But after I finished I realized that SOAP service could not start. I got the error as shown at the botton.

Whne I check, I have installed lower version of Axisi SDA file. And SAP PI wants the latest version When I try to generate another version of SDA it is always lower version, lower than the one that was original installed in PI. As a results SAP SOAP adapters and Axis adapters are not working( error: Channel not administered).

When I start service:

sap.com/com.sap.aii.adapter.soap.lib it does not start at all. Please advise

Before UPgrade
Name Version
com.sap.aii.af.axisproviderlib 7.3115.2011120717014.001
After Upgrade
Name Version
com.sap.aii.af.axisproviderlib 7.3102.20111207170812.0001

Web application [XISOAPAdapter] cannot be started. The error is: com.sap.engine.services.deploy.exceptions.ServerDeploymentException: Application sap.com/com.sap.aii.adapter.soap.app cannot be started. Reason: it has hard reference to application sap.com/com.sap.aii.adapter.soap.lib, which is not active...

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

0 Answers