Skip to Content
0

Issue with KM Document I-view

Oct 18, 2016 at 09:43 AM

79

avatar image

Hi all,

I have created a text file in KM content -> Documents -> Public Documents folder.

Then I created an KM Document I-view by giving the above path to the document.

But when I preview the I-view, the text is not displayed.

Instead by default it is showing some header image.

Could someone please let me know how to overcome this.

Thanks for all in advance.

Regards,

Avinash.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Avinash Reddy Oct 19, 2016 at 11:35 AM
0

I got the answer.

The issue is because of the cache.

Once I cleared the cache. Things are working fine.

Thanks for your reply Kamal, Steffi & Harika.

Regards,

Avinash.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Avinash,

since you posting the solution again as an answer, I went ahead and accepted it as the solution. Now others can see it directly. :)

Regards,

Steffi.

0
Kamal j Oct 19, 2016 at 08:31 AM
0

Hi Avinash,

This could be issue with the path that you've provided in the KMDocument iview. If you've created/uploaded a file in KM Content under Documents -> Public Documents folder(let's say Public_Docs and file is xyz.txt).

You should set KM doc iview property Path to document as : /Documents/Public_Docs/xyz.txt

Regards,

Kamal

Show 6 Share
10 |10000 characters needed characters left characters exceeded

Hi Kamal,

Thanks for your help.

I have given the path to document as : /documents/Public Documents/Custom Text/POC Text.txt

But when I preview the I-view, it doesn't display any text.

Thanks for your reply in advance.

Regards,

Avinash

0

Hello Avinash,

did you save the changes before starting the preview?

Regards,

Steffi.

0

Hi Steffi,

After giving the path to document, I have saved the changes.

Then when I preview, text is not displayed.

Regards,

Avinash.

0

Hmmm... could you show us a screenshot of the settings of this iview? Especially where you put the path?

The "header image" you see should be the standard file, that is linked in the document iview, when you create it. It's the path you normally replace with the one to your own file. So that you still see it after saving is really strange.

I wonder if this could be a caching issue, but I don't remember having this myself when looking at previews. Do you want to try this nevertheless? Emptying your browser cache and then preview again? Sometimes it can be something as simple as that.

.

Regards,

Steffi,

2

You are right Steffi.

It is the issue with the cache. I have been concentrating on the big picture but left this one.

Thanks for your help :)

Regards,

Avinash.

0

You're welcome!

Could you mark the question as "Closed" then? You'll find this in your Actions menu under your avatar next to the question (not the one in the header).

Then others can see that this question is answered.

Normally you would accept an answer (= correct answer), but I posted my reply as a comment, so there is no option to accept it. :)

Regards,

Steffi.

0
kavitha harika Oct 19, 2016 at 11:20 AM
0

Hello Avinash,

did you try to logoff and login again to portal and then test your preview ?

When i tested i myself observed that after changing the path for couple of times, the preview is still reflecting to the old path.

after i re logged in to portal, i was able to see the updated preview.

Also, Please go to your Text file from Km, under setting >> Properties >> you would find Access link , please copy the path from there starting from /documents/Public Documents/... .

hope this helps.

,

Hello Avinash,

Please go to your text file (under KM) and find its properties and under the Access links you will find the full path for your text file there.

please copy that path from /documents/Public Documents/....

Also, please logoff and login again to the portal and then try to preview the iview in a new session.

When i have tested for myself , i observed that after changing the path also, i was able to see the old path reflecting under preview.

hope this helps.

Share
10 |10000 characters needed characters left characters exceeded