Skip to Content

Issue with KM Document I-view

Hi all,

I have created a text file in KM content -> Documents -> Public Documents folder.

Then I created an KM Document I-view by giving the above path to the document.

But when I preview the I-view, the text is not displayed.

Instead by default it is showing some header image.

Could someone please let me know how to overcome this.

Thanks for all in advance.

Regards,

Avinash.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Oct 19, 2016 at 11:35 AM

    I got the answer.

    The issue is because of the cache.

    Once I cleared the cache. Things are working fine.

    Thanks for your reply Kamal, Steffi & Harika.

    Regards,

    Avinash.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 19, 2016 at 08:31 AM

    Hi Avinash,

    This could be issue with the path that you've provided in the KMDocument iview. If you've created/uploaded a file in KM Content under Documents -> Public Documents folder(let's say Public_Docs and file is xyz.txt).

    You should set KM doc iview property Path to document as : /Documents/Public_Docs/xyz.txt

    Regards,

    Kamal

    Add comment
    10|10000 characters needed characters exceeded

    • You're welcome!

      Could you mark the question as "Closed" then? You'll find this in your Actions menu under your avatar next to the question (not the one in the header).

      Then others can see that this question is answered.

      Normally you would accept an answer (= correct answer), but I posted my reply as a comment, so there is no option to accept it. :)

      Regards,

      Steffi.

  • avatar image
    Former Member
    Oct 19, 2016 at 11:20 AM

    Hello Avinash,

    did you try to logoff and login again to portal and then test your preview ?

    When i tested i myself observed that after changing the path for couple of times, the preview is still reflecting to the old path.

    after i re logged in to portal, i was able to see the updated preview.

    Also, Please go to your Text file from Km, under setting >> Properties >> you would find Access link , please copy the path from there starting from /documents/Public Documents/... .

    hope this helps.

    ,

    Hello Avinash,

    Please go to your text file (under KM) and find its properties and under the Access links you will find the full path for your text file there.

    please copy that path from /documents/Public Documents/....

    Also, please logoff and login again to the portal and then try to preview the iview in a new session.

    When i have tested for myself , i observed that after changing the path also, i was able to see the old path reflecting under preview.

    hope this helps.

    Add comment
    10|10000 characters needed characters exceeded