Skip to Content

Installation Stuck at Set User Environment in ABAP AS 750 & 751 SP02 on Linux

Hi Experts,

Hope you are doing well.

In last few days I did so much of RnD on this but still facing the issue in installation.

Every time my install stuck at "Set User Environment ".I got a doubt so before starting installation I used below commands also with pre-requisite command to install Java but again after that also it got stuck.

-> sudo add-apt-repository ppa:webupd8team/java

-> sudo apt update; sudo apt install oracle-java8-installer

-> javac -version

-> sudo apt install oracle-java8-set-default

INFO 2017-11-19 12:51:55.682 (root/sapinst) [CSiStepExecute.cpp:973] id=controller.executeStep Execute step createAccounts of component |offlineadjustment_dialogs|ind|ind|ind|ind|0|0|offlineadjustment_os_users|ind|ind|ind|ind|osUsers|0|NW_Users_Create_Do|ind|ind|ind|ind|setEnvironment|0

I am really not able to analyse why it is coming all the time. I tried almost 30+ times to install this but every time it is getting stuck.I tried Installing ABAP AS 750 SP02 on Linux & Installing ABAP AS 751 SP02 on Linux in both I am facing the same problem.

Can you please let me know is it required to set Java on Linux?

What is the use of "Set User Environment"?

Regards,

Varun

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Nov 21, 2017 at 10:21 AM

    Dear Varun,

    • Do you use the latest version of the SWPM? If not, please do so, following note 1680045
    • Did you create any users in advance (e.g. SIDadm or Oracle users)? If so, it's recommended do delete them and let SWPM create them.
    • Start SWPM with direct 'root' access and not using sudo or similar.

    If above is given but still the problem is present, attach the sapinst_dev.log from the installation.

    Kind regards,

    Hendrik

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Experts,

      I have installed SAP on Virtual Machine and instance are running.

      But I stuck at one place that I am not able to access SAP on my local GUI from VM.

      Can you please help me on this.

      1> SAP GUI at Local Windows System

      2> Error connection to partner '127.0.0.1:3200' broken

      3> Local Windows host file

      4> VM Network Settings

      5> VM Network Port Forwarding

      6> VM host

      7> VM IP Details

      8> VM SAP Instances

      Regards

      Varun

  • Jan 08 at 09:53 AM

    Hi Varun,

    I understand from your other question that you have solved this issue, and now have an issue with SAP GUI: https://answers.sap.com/questions/350704/installation-stuck-at-load-resource-pool-and-not-g.html?childToView=396234&answerPublished=true#answer-396234

    Is this the case? If so, please close this question.

    Best wishes Julie.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 08 at 09:53 AM

    Hi Varun,

    I understand from your other question that you have solved this issue, and now have an issue with SAP GUI: https://answers.sap.com/questions/350704/installation-stuck-at-load-resource-pool-and-not-g.html?childToView=396234&answerPublished=true#answer-396234

    Is this the case? If so, please close this question.

    Best wishes Julie.

    Add comment
    10|10000 characters needed characters exceeded