Skip to Content

MMS cockpit error - cannot load data types

Nov 17, 2017 at 06:59 PM


avatar image

please check below screenshot.

iot-mms-cockpit.jpg (164.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Anton Levin
Nov 18, 2017 at 05:24 AM

Please, check IoT FAQ [1] for two potential causes of your issue.

[1] > "IoT Cockpit" > Why does the Internet of Things service cockpit display error messages telling me that entities cannot be loaded?

Show 12 Share
10 |10000 characters needed characters left characters exceeded

Thanks this worked, the IoT service cockpit loads up data.

Now my MMS cockpit does not load up it gives message Service Unavailable.

can you help here ?




This what the log says :

Caused by: Failed to retrieve the database connection from the SAP Cloud Platform SAP HANA / SAP ASE Service. Please check if you specified a valid data source binding for the MMS in the SAP Cloud Platform Cockpit.


Same FAQ [1] > "MMS" > Why does the MMS not start or stays in state 'STARTING' or 'ERROR'? or Why does the MMS return HTTP status 500?



I have the database and schema in place but still the app does not start.

also binding exits

iot-database.jpg (82.0 kB)

What is the name of your "Data Source" in SCP Cockpit > Java Applications > iotmms > Configuration > Data Source Binding? "Data Source" has to be a default one "DEFAULT"


It is "default"

iot-database1.jpg (37.4 kB)

From the remote logs I see "SQLInvalidAuthorizationSpecException: [10]: authentication failed" exceptions when MMS tries to establish a connection with the DB. I see you are on Trial and using MDC HANA. Be advised that the default DB user is "SYSTEM" and not your P-user. Also, re-cehck the password. IoT MMS will require a restart after you do the data source re-binding.


Thanks for your quick response, the app has now started.

i get below error when i click on the cockpit link.

Access to the requested resource is forbidden (HTTP 403).


Dear user, I really insist that you read and follow the online documentation before posting questions. See IoT FAQ [1] and respective documentation about assigning roles [2].

Please, also familiarize yourself with the Community Rules of Engagements [3] and especially with:

#3 Search before you post.

#13 Do not hijack - a current question (original) is supposed to be answered. Resolution is - wrong role assignment for IoT RDMS component. Follow-up question also resolved. Resolution is - DB binding and DB credentials were wrong. Latest follow-up question - see above.

#8 Be responsive.


Anton (Moderator)

[1] > MMS > Why does the MMS return HTTP status 403?




below screenshot

iot-database2.jpg (69.8 kB)

Type your p-user correctly. "1" is missing at the end.


Thanks for all the help. It works now !