Skip to Content
avatar image
Former Member

ESS SC Import Problem

Hi There,

I am trying to import ESS600 sca into my Development system. The import ran for about 45 minutes and kicked me out of the browser with the following error ( Pl see Below ). And ever since then I can not loginto either CMS or CBS to check the status to see if the import is still running. I have looked at my CMS inbox logs at OS Level , it appears to be running from the message I see in the log.

"build process already running: waiting for another period of 30000 ms"

So , my question is , should I wait assuming that import is running ? Or Do I have a problem based on the error I get as below when I try to logonto CBS or CMS , as below.

com.sap.tc.webdynpro.services.session.LockException: Thread SAPEngine_Application_Thread[impl:3]_32 failed to acquire exclusive lock on client session ClientSession(id=(J2EE4065100)ID0000203750DB10248335311291083275End_1368558993). Existing locks: LockingManager(ThreadName:SAPEngine_Application_Thread[impl:3]_32, exclusive client session lock: ClientSessionLock(SAPEngine_Application_Thread[impl:3]_14), shared client session locks: ClientSessionSharedLockManager([]), app session locks: ApplicationSessionLockManager([]), current request: sap.com/tcSLCMS~WebUI/Cms).Hint: Take a thread dump of the server node to find the blocking thread that causes the problem.

at com.sap.tc.webdynpro.clientserver.session.ClientSession$LockingManager.lock(ClientSession.java:1511)

at com.sap.tc.webdynpro.clientserver.session.ClientSession.doProcessing(ClientSession.java:233)

at com.sap.tc.webdynpro.clientserver.session.RequestManager.doProcessing(RequestManager.java:149)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doContent(DispatcherServlet.java:62)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doGet(DispatcherServlet.java:46)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:401)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:266)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:387)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:365)

at com.sap.engine.services.httpserver.server.RequestAnalizer.invokeWebContainer(RequestAnalizer.java:944)

at com.sap.engine.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:266)

at com.sap.engine.services.httpserver.server.Client.handle(Client.java:95)

at com.sap.engine.services.httpserver.server.Processor.request(Processor.java:175)

at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:33)

at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41)

at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

at java.security.AccessController.doPrivileged(Native Method)

at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:100)

at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:170)

Please Suggest...

Regards

Venu

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Feb 03, 2008 at 12:53 AM

    Any tips Gentlemen ? It's been almost 24 hours since I started the import of ESS600_SP10 Component. Still running with the following message in the logs , Is it usual ? Can I wait ?

    20080202183756 Info :waiting for CBS queue activity

    20080202183836 Info :build process already running: waiting for another period of 30000 ms

    20080202183906 Info :build process already running: waiting for another period of 30000 ms

    20080202183937 Info :build process already running: waiting for another period of 30000 ms

    20080202184007 Info :build process already running: waiting for another period of 30000 ms

    20080202184037 Info :build process already running: waiting for another period of 30000 ms

    20080202184108 Info :build process already running: waiting for another period of 30000 ms

    Please advice..

    Regards

    Venu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 03, 2008 at 07:21 PM

    Thank you , Dan .

    But I have idlestart set to false already.

    Regards

    Venu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 05, 2008 at 08:28 PM

    I had this problem several times and only was able to solve it with IT rule number 1 (when in doubt , reboot!).

    I noticed that buildspace in question showed Input = Priveldged. I ended up changing it to "Open" and then starting over.

    I reported this to SAP via an OSS message but they said that I and one other customer were the only ones to report it.

    Cheers ... Bart

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 05, 2008 at 08:53 PM

    Bart-

    Thanks for taking time and sharing your experience on this issue. This has been teasing me for the past one week , SAP hasn't come up with any solution so far. Will update this thread when I have the answer.

    In short , the problem is Not able to import ESS600_SP10 SC into CMS , It gets stuck in an endless loop spitting an INFO mesage in the log that says some thing like "Waiting for Build space queued requests to be processed before running the import , wait time 30000 msec" and aborts after 4 to 6 hours.

    I was able to import all other SC's for XSS except the ESS one.

    Regards

    Venu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      BTW, my import had nothing to do with an ESS import - the aforementioned message was found during normal track creation for an in-house project.

  • avatar image
    Former Member
    Feb 11, 2008 at 06:09 PM

    Just wanted to update this thread with my findings to help others who might encounter the same problem.

    After analysis by SAP MaxDB experts , it turned out to be Optimizer Stats issue. We had to run optimizer stats job frequently to gather accurate statistics to improve the performance of ESS SC imports.

    Our DB was MaxDB 7.6 with SP13 AS Java and DI. The ESS SP version was 10 , running HPUX 11 PA-RISC platform.

    After the stats were updated , imports were flying. My take on this ESS import slowness issue is , if any of the ESS SC component import runs beyond 2 to 3 hours , then there is must be some thing wrong with your configuration or DB issue like in my case , stale statistics.

    Regards

    Venu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Venu,

      I am facing the same problem when I try to open the portal pages, Some times this works fine and some times it shows error in all the pages like below

      com.sap.tc.webdynpro.services.session.LockException: Thread SAPEngine_Application_Threadimpl:3_33 failed to acquire exclusive lock on client session ClientSession(id=(J2EE1297700)ID1636161150DB01313596806023592431End_1830338394). Existing locks: LockingManager(ThreadName:SAPEngine_Application_Threadimpl:3_33, exclusive client session lock: ClientSessionLock(SAPEngine_Application_Threadimpl:3]_26), shared client session locks: ClientSessionSharedLockManager([), app session locks: ApplicationSessionLockManager([]), current request: sap.com/tcSLCMS~WebUI/Cms).Hint: Take a thread dump of the server node to find the blocking thread that causes the problem.

      Here are our server details

      EP7.0 SP13, DB : Oracle10G. OS Solaris 10 (Sparc)

      Please help me to solve the issue.

      Regards

      Ponnusamy P

  • avatar image
    Former Member
    Apr 21, 2008 at 02:41 PM

    Ponnuswamy-

    I am not sure what do you mean by "when opening portal pages". We have had this issue on NWDI system and not Portals. If you meant NWDI , then it's a normal behaviour to see "Unable to acquire an exclusive lock " when a massive CMS import is in Progress" You won't be able to get into CMS. But you can keep tailing the logs at OS level to check the progress. You need to be real patient if you are importing any ESS components. And make sure you have Optimizer statistics up-to-date at DB Level to improve the import performance.

    Again , this has been my experience , there could be a better way to make things work as expected.

    Regards

    Venu

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ponnuswamy,

      I'm experimenting the same problem than you... I've integrated Learning BP workflow in the UWL and when I try to open a decision task (a Web Dynpro) it hangs and it shows a lock exception. When it happents this user can't execute any web dynpro application because it hangs too and finally the portal restarts.

      Dis you colve this problem? How?

      Thanks in advance and best regards...

      jc!

  • Jan 09, 2009 at 11:23 AM

    Concerning 'webdynpro lock issue': Note 1234847 may provide more details on why this happens.

    Usually the easiest way to continue is to open a second browser session, to continue working as long as the 'long-running process' blocks the 'old' browser session.

    Hope this can help.

    Add comment
    10|10000 characters needed characters exceeded