Skip to Content
0

HTTP_AAE URL not working

Nov 14, 2017 at 08:49 AM

203

avatar image
Former Member

Hello Experts,

I am working on a scenario HTTP_AAE to IDOC.

I had generated URL but it is showing me below error.

below is my sender channel:

below is the URL I am testing:

http://ravi.abc.com:xxxxx/HttpAdapter/HttpMessageServlet?∫erfaceNamespace=http://abc.com/xxx/xxx/xxx∫erface=SI_xxx_xxx_ASYN_OB>& senderService=BC_xxx&senderParty=&receiverParty=&receiverService=ecc&qos=EO

Kindly suggest the solution.

Thanks,

Ravi

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Sanjali Salian Nov 14, 2017 at 10:14 AM
0

Hi Ravi,

Have you tried posting a message to this endpoint?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 14, 2017 at 11:43 PM
0

Issue is with the '>' after the interface and before senderService. Remove that and it will work.

http://ravi.abc.com:xxxxx/HttpAdapter/HttpMessageServlet?∫erfaceNamespace=http://abc.com/xxx/xxx/xxx∫erface=SI_xxx_xxx_ASYN_OB>& senderService=BC_xxx&senderParty=&receiverParty=&receiverService=ecc&qos=EO

PS - No point in hiding information using xxxx in the URL, all values are visible in the screenshot :)

Cheers,

Vibhu

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Vibhu,

I removed '>' sign but still, I am getting the same error.

0
Andrzej Filusz Nov 15, 2017 at 10:22 AM
0

Hi Ravi,

Please apply the following note:

2508664 - Missing feature in HTTP_AAE adapter for Namespace availability in target URL

The new parameter 'includeNamespace' should solve that issue.

Regards,

Andrzej

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Andrzej,

mine is sender HTTP_AAE channel and the note you provided is for Receiver channel.

can you suggest me for sender channel!!??

0

Hi Ravi,

I'm sorry I understood your scenario incorrectly.

There was a typo in your URL so as I understand you created it manually. Could you please get a WSDL link from Sender Agreement --> Display WSDL... or Integrated Configuration --> Display WSDL... and use it to create a project in SoapUI? Then you can copy the generated URL from the request example. In this way we will be sure that your URL is correct.

Regards,

Andrzej

0
Former Member
Andrzej Filusz

Hi Andrzej,

when I clicked on Display WSDL in ICO it gives me below error:

"Selected communication channel is assigned to the wrong adapter type HTTP_AAE Supported adapter types: HTTP, SOAP, XI, WS."

In PO 7.5 HTTP adapter is not available.

0