Skip to Content
author's profile photo Former Member
Former Member

Visual Admimistrator wont connect to NW2004s Java ABAP on Linux VMware

My VA wont connect to the server giving the following trace in /j2ee/admin/log/traces/visual_administration.0.trc:

#1.5#C0007F0000010008000000010000C550000444EEE28D5508#1201692700661#com.sap.engine.services.adminadapter.gui.tasks.LoginTask##com.sap.engine.services.adminadapter.gui.tasks.LoginTask#######Thread[Thread-61,6,main]##0#0#Error#1#/System/Server/VisualAdministrationTool#Java###Error while trying to login to localhost: Cannot create new RemoteLoginContext.

[EXCEPTION]

#1#com.sap.engine.services.security.exceptions.BaseLoginException: Cannot create new RemoteLoginContext.

at com.sap.engine.services.security.remote.login.RemoteLoginContext.<init>(RemoteLoginContext.java:71)

at com.sap.engine.services.adminadapter.gui.tasks.LoginTask.connectAction(LoginTask.java:96)

at com.sap.engine.services.adminadapter.gui.tasks.LoginTask.run(LoginTask.java:79)

at java.lang.Thread.run(Thread.java:534)

Caused by: com.sap.engine.services.rmi_p4.P4IOException: Cannot open connection on host: 127.0.0.1 and port: 54200

at com.sap.engine.services.rmi_p4.P4ObjectBrokerClientImpl.getException(P4ObjectBrokerClientImpl.java:698)

at com.sap.engine.services.rmi_p4.ConnectionManager.getConnection(ConnectionManager.java:252)

at com.sap.engine.services.rmi_p4.P4ObjectBrokerClientImpl.resolveInitialReference(P4ObjectBrokerClientImpl.java:149)

at com.sap.engine.services.rmi_p4.P4ObjectBrokerClientImpl.resolveInitialReference(P4ObjectBrokerClientImpl.java:114)

at com.sap.engine.services.rmi_p4.P4ObjectBrokerClientImpl.resolveInitialReference(P4ObjectBrokerClientImpl.java:110)

at com.sap.engine.services.security.remote.login.RemoteLoginContext.<init>(RemoteLoginContext.java:60)

... 3 more

The server is the NW2004s SP9 Java and ABAP stack on VMware from SDN. The J2EE server starts up OK I can access it via http://localhost:8042 and 54200 and use the admin apps. SystemInfo

displays the dispatcher ports as:

HTTP Port: 54200

HTTPS Port: 54201

P4 Port: 54204

Telnet Port: 54208

I've tried connecting VA using a direct connection to the dispatcher on ports 54200,54204,8042 and it gets to around 70% in the progress bar

and says 'Cannot open connection on host: 127.0.0.1 and port: 54200'.

I checked J2EE_ADMIN has the SAP_J2EE_ADMINISTRATOR role in SU01 and the password is correct, and the user is unlocked.

Can anyone suggest a solution?

Has anyone managed to connect VA to the 2004s Java ABAP stack on VMware?

Cheers,

Steve

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2008 at 12:57 PM
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.