Skip to Content

Creating Variable in C4A

Nov 14, 2017 at 07:27 AM


avatar image

Hi all,

when I am trying to create variables in model, it throwing an error. please find below screen shots. Source system is: C4C Analytics.

please assist me on this.

Thanks & Regards,


ocezt.png (11.6 kB)
nyibf.png (29.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Petar Daniel Nov 14, 2017 at 07:59 PM


Not exactly certain how we can help in this forum, so I suggest you need to open a SAP support ticket if these ideas do not assist you.

- If you are building any model from a source or file, before attempting to add variables, I suggest saving the model as is loaded and defined. You can then exit modeling, enter a story and just verify that you can see or add data to the story.

- If you are building a planning style model, I suggest verifying that your security profile and authorization.

- If this is an analytic model, again I would verify that you have the security to maintain/update the model.

If the issue persists, then I suspect someone from SAP will need to look at your issue in a support session.

Hope this helps, but also let us know if you find a resolution.


Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Peter,

as you said in first point, we already did same steps only.

My source system C4C for analytics. from C4C Analytics we took one query and built one model. after successful model creation, we try to add variables from Modeling, there we are getting application error.

we tried with same for other models (Which are already developed), here also same error.

I have one doubt regarding Hana input variables. as of now we don't have connectivity between Hana on promise to C4A.

My doubt is if I create input variables r parameters in Hana views, will same variables support in C4A are not. ?
please advise on this.