Skip to Content
0

CR XI report not finishing-Completing but query run Ok on SQL

Nov 14, 2017 at 09:58 PM

25

avatar image
Former Member

Hello

I am using CR version 11.5.12.1838 and I am have several reports that I run locally on my PC and also within our ERP system and the reports has always worked but in the last few days I am having some issues where I will start the report and it will work OK for one customer no but if I try to run the report for all customers then I can see in the database Yes the report is running and after 20mn then I do not see anything in the database anymore but the report is not complete and still just spinning around and I have taken the exact query that is running on the CR and did paste that in sql/toad and it took 20mn to run but I am sure what else to look for,

The same report works OK with for other companies but those have less data than the one I am having an issue with but it has always worked, never had issues before, when report is running I can see in the database that's using the indexes OK . Our DB has rebuild the indexes in the db but all indexes are valid and the report is working for one customer and all other customers for other companies

Anything else i should be looking at? is there a log somewhere on my local PC for CR, is it because CR is not displaying the data on the screen is that why I no longer see anything activity on the DB? what may be causing this? any idea?

Than you for your help

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Brian Dong Nov 14, 2017 at 11:32 PM
0

Hi,

If the query takes 20 minutes to run in toad then I suspect Crystal may be timing out.

What database are you using?

How are you connecting to the database?

Is there an updated database driver you can use?

Check the database logs and see if there are any locks or timeouts.

Good luck,
Brian

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you Brian, I am using an Oracle DB version 11. I found that we were having some issues with our network and that's why the report was not finishing for that company since it was lot of data coming back but still not sure why CR would not finish or just error out

0

Hi,

Crystal is waiting for a record set to be returned or a response from the server. I don't think I've ever seen Crystal return an error when the connection is terminated prematurely. You'll get one when it can't connect but once the connection is established, I don't think Crystal returns network errors.

Brian

0