Skip to Content
2

Trial Region DB Service: Error [132]

5 days ago

40

avatar image

I'm curious if anyone has recently experienced problems accessing the database services on trial accounts in SAP Cloud Platform? The problem in particular appears to be related at the very least to INSERT statements. Here's the specific error message I'm getting:

Could not execute 'insert into "NEO_<ID>"."TEST_TEXT" values('AA','BCD')' in 2.378 seconds . 
SAP DBTech JDBC: [132]: transaction rolled back due to unavailable resource 

I first noticed this problem on November 13th when attempting a fresh deployment of a java app in the neo environment. The deployment was carried out with a script that automates creation of schemas (w/ database system HANA <shared>) and bindings of those schemas to datasources. The app itself makes use of liquibase to automate the schema initialization and adjustments. My last successful use of this script was on Friday, November 11th.

The reason I believe this is related to record inserts is the way liquibase operates. The first thing it does is try to setup a DATABASECHANGELOGLOCK table. This table is created successfully but the very next step is to insert a record into this table. It is this INSERT that fails.

Observing that inserts fail, I tried to manually create a table using the SAP HANA Administration Console in Eclipse to create a new table and test out inserts. I was able to successfully create a table using the following SQL:

CREATE ROW TABLE "NEO_<ID>"."TEST_TEXT" ( 
	 "ID" NVARCHAR(2) CS_STRING NOT NULL,
	 "TEST_VALUE" NVARCHAR(255) CS_STRING,
	 PRIMARY KEY ( "ID" ) ) 

But my attempt to insert a record using the following SQL results in the [132] error listed above:

insert into "NEO_<ID>"."TEST_TEXT" values('AA','BCD')

Can anyone confirm if they've experienced similar issues or provide guidance on how to resolve a [132] error?

Note: I've also been monitoring https://sapcp.statuspage.io/ but have not found any issues reported with the trial region.

UPDATE November 15:

The database woes continue but now it isn't even possible to operate on bindings, either through the neo console client or cloud cockpit.

Here's what it looks like when attempting to create a binding in the cockpit:

Here's what it looks like when attempting to delete a binding in the cockpit:

I've also attached the logs when attempting the same actions through the console client.

console-create-schema.txt console-delete-schema.txt

So I'm really starting to think this is an issue with the platform itself, yet the status page indicates everything is fine. Is everything fine, am I making a mistake somewhere?

10 |10000 characters needed characters left characters exceeded

It appears that somebody else other than Cody and I have finally noticed there is a problem. Here are the relevant links:

Hopefully this will be solved on SAP's side.

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Cody Deckard 5 days ago
1

Hi Brian,

I'm also running into this error while trying to insert a record using a java application on my hana trial account.

Internal Exception: com.sap.db.jdbc.exceptions.JDBCDriverException: SAP DBTech JDBC: [132]: transaction rolled back due to unavailable resource
Error Code: 132
Call: INSERT INTO TASKS (GUID, CREATION_DATE, CREATED_BY, description, MODIFICATION_DATE, MODIFIED_BY, title) VALUES (?, ?, ?, ?, ?, ?, ?)
	bind => [8c7eadbe-4262-4f5d-a6fc-448eef97b5cf, 2017-11-14 19:21:08.677, username, Task Description, 2017-11-14 19:21:08.677, username, Task title]
Query: InsertObjectQuery(Task - ID: 8c7eadbe-4262-4f5d-a6fc-448eef97b5cf Title: Task title Desc: Task Description Created by: username)
Share
10 |10000 characters needed characters left characters exceeded