Skip to Content
author's profile photo Former Member
Former Member

Disabled Add Button on Visual Adminitrator

Hello there,

I'm following this steps to add J2EE_admin user into the administartor users

1. Start the Visual Administrator.

2. Go to Server -> Services -> Security

Provider

3. Choose the ?Security Roles? tab.

4. Choose component ?SAP-J2EEEngine?.

5. Choose the ?administrators? role and

choose the ?Add? under Users.

6. Specify ?J2EE_ADMIN? and hit

Search. Choose ?J2EE_ADMIN? and

hit OK.

7. Make sure the ?J2EE_ADMIN? user

exists under Users.

8. Choose KeyStoreViewCreator and

make sure the user ?J2EE_ADMIN?

is added to that role as well.

The problem is that whem I get to step 5, the add button is disabled

Any ideas ?

Thank

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 10:31 PM

    Are you clicking on 'Change' icon when you reach step 5 ? It is a pencil icon right above 'Runtime'.

    Does it remain disabled even after clicking on the change icon ?

    Best Regards,

    Snehal

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you very much, the button is enabled now!

      But, unfortunally I facing another problem on step 6 now:

      6. Specify “J2EE_ADMIN” and hit

      Search. Choose “J2EE_ADMIN” and

      hit OK.

      When I search for J2EE_ADMIN there ain't any. There is no J2EE_ADMIN user!

      What shall I do?

      Thanks

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2008 at 07:46 AM

    Hi Jose,

    I think you have dont have permissions to modify the backend abap users from your java system.So you have to add the role

    SAP_BC_JSF_COMMUNICATION to your sapjsf user.By default SAP_BC_JSF_COMMUNICATION_RO will be assigned to SAPJSF user.If you want to modify the users in your visual admin assign the above role.You have to generate the profile for SAP_BC_JSF_COMMUNICATION because that doesn't come with a profile.You can do this by the tcode 'SUCP'.

    reward points if helpfull.

    Regards,

    Vamshi.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2008 at 06:31 PM

    Is this a java stack only or ABAP+Java ?

    If it is ABAP+Java - dual stack installation, the administrator user is j2ee_admin. It should exist as its created during the installation.

    If it is java stack only, the admin user is 'administrator'.

    From your response, it looks like you have java only stack. Is that true ?

    regards,

    Snehal

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2008 at 06:36 PM

    Hi Jose,

    Why you want to add the J2EE_USER user in administrator user?

    Best Wishes.

    Kumar

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Kumar and Snehal

      Yes I'm using only java stack

      The problem started when I tried to deploy an EAR file from Studio

      I got problems with my password

      After I chenged the password I'm having problems with authorization.

      I get an error saying that the user is not authorized for deployment.

      I'm confused now. Which user is responsable for deployment ?

      Must I give adminastrive role to that user ?

      I will post the exact error message later or maybe tomorow because I can't now.

      Best Regards

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2008 at 08:26 PM

    Since its only java stack, you should look for 'Administrator' user. You will surely find it. This user by default does have administrative privileges unless changed.

    You should be able to make deployment using the Administrator user.

    Best regards,

    Snehal

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      This is the error that I get when I try to deploy.

      PLease help me!

      Settings

      SDM host : vm2003server

      SDM port : 50018

      URL to deploy :

      file:/C:/DOCUME1/JOS1/CONFIG~1/Temp/temp17955JSP_teste_EAR.ear

      Result

      => deployment aborted : file:/C:/DOCUME1/JOS1/CONFIG~1/Temp/temp17955JSP_teste_EAR.ear

      Aborted: development component 'JSP_teste_EAR'/'sap.com'/'localhost'/'2008.01.20.13.59.18':

      Caught exception during application deployment from SAP J2EE Engine's deploy service:

      java.rmi.RemoteException: Only Administrators have the right to perform this operation.

      (message ID: com.sap.sdm.serverext.servertype.inqmy.extern.EngineApplOnlineDeployerImpl.performAction(DeploymentActionTypes).REMEXC)

      Deployment exception : The deployment of at least one item aborted

      Edited by: Jose Luis Gonzalez Clua on Jan 31, 2008 4:26 PM

  • author's profile photo Former Member
    Former Member
    Posted on Jan 31, 2008 at 06:06 PM

    Hello Jose,

    Please open confit tool - secure store -

    Its possible that you have specified J2EE_Admin instead of Administrator there. The user should be administrator. The password should be correct for the administrator.

    Make sure SAP note 701654 is followed.

    Regards,

    Snehal

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you very much for your help.

      I got it working now!

      The correct user was neither 'J2EE_ADMIN' (doesn't exist for only java stack) or 'Administrator'.

      The correct user for java stack is 'admin' !

      after i gave 'admin' administrator role the deplyment started to work!!

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.