Skip to Content
0

SMTP Port 25 not getting activated

Nov 15, 2017 at 01:34 AM

158

avatar image

Hi Experts,

SMTP Port 25 is not getting activated. I have gone through the note 2089881.

I get below error for ports 25, 25000 and 25001.

Permissions for icmnbd are: 4750 (-rwsr-x---)

[Thr 140489157240576] *** ERROR => IcmBindService: You might not have the permissions to bind the service:

<hostname>:25 [icxxserv.c 3843]
[Thr 140489157240576] *** ERROR => IcmBindService: NiBuf3Listen failed for host

<hostname>(IP):25 (rc=-16): NIEMYHOST_VERIFY [icxxserv.c 3851]
[Thr 140489157240576] *** WARNING => IcmAddService: Could not start service (rc=-1) HOST=<hostname>,PORT=25,PROT=SMTP,TIMEOUT=120,PROCTIMEOUT=1000 [icxxserv.c 1311]
[Thr 140489157240576] Started service HOST=

<hostname>,PORT=25001,PROT=SMTP,TIMEOUT=120,PROCTIMEOUT=1000

Please advice.

Thanks,

Asad

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Nov 27, 2017 at 11:55 AM
0

Hi,

The ownership of icmnbd should be root.

Try the below command

root> cd /usr/sap/SID/SYS/exe/run

root> chown root:sapsys icmbnd

root> chmod 4750 icmbnd

root> cd /usr/sap/SID/<Instance>/exe (for example <Instance>=DVEBMGS00)

root> chown root:sapsys icmbnd

root> chmod 4750 icmbnd

Stopsap and start it, Now try activating the SMICM.

Share
10 |10000 characters needed characters left characters exceeded
Isaias Freitas
Nov 27, 2017 at 11:57 PM
0

Hello,

NIEMYHOST_VERIFY

Confirm that the hostname used at the parameter "icm/server_port_X = HOST=<hostname>,PORT=25,PROT=SMTP, ..." is correct / a local hostname.

That error keyword is usually related to the hostname not being local, so the ICM cannot bind to the IP address of that host.

Regards,

Isaías

Share
10 |10000 characters needed characters left characters exceeded