Skip to Content
0

SAP PI 7.4 (Dual stack) Sender WS Adapter - Error while creating Sender Agreement

Nov 14, 2017 at 03:26 AM

42

avatar image
Former Member

Hi Experts,

I am trying to implement Sender WS adapter fetching data from MDG in a classical configuration scenario and I am getting the below error while creating the Sender Agreement.

Please let me know if there is a fix for this issue?

Regards,

Arkesh

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Ankit Kansal Nov 14, 2017 at 07:04 AM
0

Hi Arkesh,

Could you please share the details of your service interface ? what is the interface pattern you defined - stateless or stateless(XI30-compatible) ?

Regards,

Ankit Kansal

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Ankit,

The sender interface is standard interface provided by SAP and its interface pattern is "Stateless (XI3.0 Compatible)" with point-to-point checkbox ticked/enabled. I have been told not to modify or change the service interface in any way as it will impact the already generated proxy.

Regards,
Arkesh

0

Hi Arkesh,

If it is proxy you can use SOAP adapter instead of WS adapter. So, that it will support xi3.0 compatible interfaces.

Is there any specific requirement which you are using WS adapter?

Regards

Pavan

0
Former Member
Pavan Dogiparthy

Hi Pavan,

We have been specifically told to use WS Adapter because MDG replicates data from Production to other PI Environments (i.e. Dev and QA). We tried entering multiple PI destinations in SXMB_ADM of MDG but that is not working out for us. Since MDG is using standard SAP-provided interface to send data, we are told not to touch the standard interface.

Regards,
Arkesh

0

Hi Arkesh,

In case of stateless(XI 3.0 compatible) interface pattern, service definition is only created if the operation is synchronous operation. I hope you are using sync call.

Other thing is, By default, Internet Communication Manager (ICM) ports are deactivated in business systems to prevent unwanted system access. When we want to enable communication based on the proxy or web services runtime, we need to activate the corresponding ICM ports in the business systems. Make it confirm if the ports are activated or not.

Regards,

Ankit Kansal

0