Skip to Content
avatar image
Former Member

WEB IDE for SAP HANA SPS 12 : webide fails with error installing NPM Module

Hi Experts,

I have successfully installed XSA runtime 1 .

while installing webide i am getting following error msgs:-

Installing npm modules... npm ERR! Linux 4.4.74-92.38-default npm ERR! argv "/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/vendor/node6.11/bin/node" "/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/vendor/node6.11/lib/node_modules/npm/bin/npm-cli.js" "install" "--production" npm ERR! node v6.11.1 npm ERR! npm v3.10.10 npm ERR! code ECONNRESET npm ERR! network tunneling socket could not be established, statusCode=403 npm ERR! network This is most likely not a problem with npm itself npm ERR! network and is related to network connectivity. npm ERR! network In most cases you are behind a proxy or have bad network settings. npm ERR! network npm ERR! network If you are behind a proxy, please make sure that the npm ERR! network 'proxy' config is set properly. See: 'npm help config' npm ERR! Please include the following file with any support request: npm ERR! /hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/npm-debug.log Error: Command failed: "/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/vendor/node6.11/bin/npm" install --production Error: Command failed: "/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/vendor/node6.11/bin/npm" install --production at checkExecSyncError (child_process.js:468:13) at Object.execSync (child_process.js:508:13) at execSync (/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/cache/dda0a40b-6e31-4c5b-a709-74a8261b0354/lib/utils.js:18:16) at Object.exports.npmInstall (/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/cache/dda0a40b-6e31-4c5b-a709-74a8261b0354/lib/utils.js:153:5) at main (/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/cache/dda0a40b-6e31-4c5b-a709-74a8261b0354/lib/compile.js:45:9) at next (native) at onFulfilled (/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/cache/dda0a40b-6e31-4c5b-a709-74a8261b0354/node_modules/co/index.js:65:19) at process._tickCallback (node.js:460:9) Execution of bin/compile failed (exit value 1) Failed to stage app 'javatools' [Org 'orgname', Space 'SAP']: Execution of bin/compile failed (exit value 1). Error staging application "javatools": 200 Application staging failed ---------------- deploy service END -------------------------------- Error staging application "javatools": 200 Application staging failed Error staging application "javatools": 200 Application staging failed Installation of the component XSAC_SAP_WEB_IDE (sap.com) 4.2.3 failed during deployment.

I tried with WEBIDE4.0 package that came along with XSA advanced runtime but it also failed with same error.
Please find the attached files

1. showing all services running for XSA

2. detailed installation log of WEB IDE

Note : I am installing these components on an independent server , on a virtual machine.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 29 at 08:14 AM

    Issue is resolved.

    Just update the /etc/security/pam_env.conf and /etc/environment files with right proxy .
    This is just the proxy error and nothing else.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 14, 2017 at 01:14 PM

    looks to be a proxy issue. Try:

    strings /proc/9580/environ | grep -i proxy

    xs ssevg '{"no_proxy":"{xsa-placeholder-domain-default},$no_proxy","NO_PROXY":"{xsa-placeholder-domain-default},$NO_PROXY"}'

    xs srevg '{"no_proxy":"{xsa-placeholder-domain-default},$no_proxy","NO_PROXY":"{xsa-placeholder-domain-default},$NO_PROXY"}'

    run the following installation command again:

    xs install XSACSAPWEBIDE02_2-80002257.ZIP -e sap-xsac-devx.mtaext -o ALLOW_SC_SAME_VERSION>out.txt

    If this doesnt work, clean the webide and reinstall from the beginning

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Michael

      I ran these command. Still i got same error.

      ndbadm@agrl50931915n:/usr/sap/NDB/HDB00> xs ssevg '{"no_proxy":"{xsa-placeholder-domain-default},$no_proxy","NO_PROXY":"{xsa-placeholder-domain-default},$NO_PROXY"}'

      Setting the contents of the staging environment variable group as XSA_ADMIN...

      Variable Name Assigned Value

      ----------------------------------------------------------

      no_proxy {xsa-placeholder-domain-default},$no_proxy

      NO_PROXY {xsa-placeholder-domain-default},$NO_PROXY

      ndbadm@agrl50931915n:/usr/sap/NDB/HDB00> xs srevg '{"no_proxy":"{xsa-placeholder-domain-default},$no_proxy","NO_PROXY":"{xsa-placeholder-domain-default},$NO_PROXY"}'

      Setting the contents of the running environment variable group as XSA_ADMIN...

      Variable Name Assigned Value

      ----------------------------------------------------------

      no_proxy {xsa-placeholder-domain-default},$no_proxy

      NO_PROXY {xsa-placeholder-domain-default},$NO_PROXY

  • Nov 18, 2017 at 03:12 PM

    Hi Karishma & Michael,
    had the same issue here on my HANA Express. I just ran the 'xs ssevg...' & 'xs xrevg...' command as suggested by Michael.
    Afterwards the xs install ...zip (without any further paarmeters) went trough without errors.
    Thanks you both for opening & answering, much apprechiated!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sebastian,

      i am having this issue on HANA platform edition. I ran these command. Still i got same error while installing webide.

      ndbadm@agrl50931915n:/usr/sap/NDB/HDB00> xs ssevg '{"no_proxy":"{xsa-placeholder-domain-default},$no_proxy","NO_PROXY":"{xsa-placeholder-domain-default},$NO_PROXY"}'

      Setting the contents of the staging environment variable group as XSA_ADMIN...

      Variable Name Assigned Value

      ----------------------------------------------------------

      no_proxy {xsa-placeholder-domain-default},$no_proxy

      NO_PROXY {xsa-placeholder-domain-default},$NO_PROXY

      ndbadm@agrl50931915n:/usr/sap/NDB/HDB00> xs srevg '{"no_proxy":"{xsa-placeholder-domain-default},$no_proxy","NO_PROXY":"{xsa-placeholder-domain-default},$NO_PROXY"}'

      Setting the contents of the running environment variable group as XSA_ADMIN...

      Variable Name Assigned Value

      ----------------------------------------------------------

      no_proxy {xsa-placeholder-domain-default},$no_proxy

      NO_PROXY {xsa-placeholder-domain-default},$NO_PROXY

  • avatar image
    Former Member
    Dec 21, 2017 at 11:36 AM

    Hello Karishma & Michael,
    had the same issue my HANA Express Binary Installation on SUSE Linux. Obtained the same error message with npm inside of WEBIDE package. With above explanation I could solve it. Finally I did:

    1. HANA Express installation with the option server & data provisioning
    2. HANA Express installation setup script. The second time it recognizes that server component is given and only asks for XSA setup. The installation runs until the npm package inside WEBIDE. The npm trace file points to an PROXY issue
    3. As sidadm, connecting to xs login -u XSA_ADMIN and executing above commands:

    xs ssevg '{"no_proxy":"{xsa-placeholder-domain-default},$no_proxy","NO_PROXY":"{xsa-placeholder-domain-default},$NO_PROXY"}'

    xs srevg '{"no_proxy":"{xsa-placeholder-domain-default},$no_proxy","NO_PROXY":"{xsa-placeholder-domain-default},$NO_PROXY"}'

    Run the following installation command again:

    xs install XSACSAPWEBIDE02_<...>.zip -e <....>.mtaext -o ALLOW_SC_SAME_VERSION>out.tx

    4. Install the missing components, which would be installed after the SAPWEBIDE setup. In my case, inside the XSA_CONTENT_10 subfolder:
    xs install XSACSERVICES05_3.ZIP -o ALLOW_SC_SAME_VERSION>XSACSERVICES05_out.txt
    xs install XSACUI5FESV344_23.zip -o ALLOW_SC_SAME_VERSION>XSACUI5FESV344_out.txt


    Add comment
    10|10000 characters needed characters exceeded

  • May 09 at 07:47 AM

    Pls dont forgett to install the Proxy lateron in the WebIDE MTAEXT File if needed, as otherwise no proxy will be used and we tried to solve this problem for weeks now. Finally with WebIDE 4.3.1 we were able to customize the mtaext file and run the webide installation with setting proxy for maven (di-core/di-runner) and npm

    Add comment
    10|10000 characters needed characters exceeded