Skip to Content
2
Former Member
Nov 13, 2017 at 07:55 AM

WEB IDE for SAP HANA SPS 12 : webide fails with error installing NPM Module

2210 Views Last edit Nov 14, 2017 at 11:04 AM 2 rev

Hi Experts,

I have successfully installed XSA runtime 1 .

while installing webide i am getting following error msgs:-

Installing npm modules... npm ERR! Linux 4.4.74-92.38-default npm ERR! argv "/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/vendor/node6.11/bin/node" "/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/vendor/node6.11/lib/node_modules/npm/bin/npm-cli.js" "install" "--production" npm ERR! node v6.11.1 npm ERR! npm v3.10.10 npm ERR! code ECONNRESET npm ERR! network tunneling socket could not be established, statusCode=403 npm ERR! network This is most likely not a problem with npm itself npm ERR! network and is related to network connectivity. npm ERR! network In most cases you are behind a proxy or have bad network settings. npm ERR! network npm ERR! network If you are behind a proxy, please make sure that the npm ERR! network 'proxy' config is set properly. See: 'npm help config' npm ERR! Please include the following file with any support request: npm ERR! /hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/npm-debug.log Error: Command failed: "/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/vendor/node6.11/bin/npm" install --production Error: Command failed: "/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/work/5d795292-642f-4de6-8f8f-b900b7acf929-65/droplet/app/vendor/node6.11/bin/npm" install --production at checkExecSyncError (child_process.js:468:13) at Object.execSync (child_process.js:508:13) at execSync (/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/cache/dda0a40b-6e31-4c5b-a709-74a8261b0354/lib/utils.js:18:16) at Object.exports.npmInstall (/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/cache/dda0a40b-6e31-4c5b-a709-74a8261b0354/lib/utils.js:153:5) at main (/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/cache/dda0a40b-6e31-4c5b-a709-74a8261b0354/lib/compile.js:45:9) at next (native) at onFulfilled (/hana/shared/NDB/xs/app_working/stager/stager-sapndbxsa/cache/dda0a40b-6e31-4c5b-a709-74a8261b0354/node_modules/co/index.js:65:19) at process._tickCallback (node.js:460:9) Execution of bin/compile failed (exit value 1) Failed to stage app 'javatools' [Org 'orgname', Space 'SAP']: Execution of bin/compile failed (exit value 1). Error staging application "javatools": 200 Application staging failed ---------------- deploy service END -------------------------------- Error staging application "javatools": 200 Application staging failed Error staging application "javatools": 200 Application staging failed Installation of the component XSAC_SAP_WEB_IDE (sap.com) 4.2.3 failed during deployment.

I tried with WEBIDE4.0 package that came along with XSA advanced runtime but it also failed with same error.
Please find the attached files

1. showing all services running for XSA

2. detailed installation log of WEB IDE

Note : I am installing these components on an independent server , on a virtual machine.

Attachments

services.txt (3.7 kB)