Skip to Content
0

Connecting to SAP Developer edition from windows

Nov 12, 2017 at 12:30 PM

101

avatar image
Former Member

Hi Everyone,

I've successfully installed my SAP developers edition using opensuse on VirtualBox. I've ocnfigured the port forwarding and started the SAP server. However, I'm unable to connect to the SAP system in virtualbox from Windows?

Any idea where I might be going worng or what settings I need to check?

I followed this article to the letter: https://blogs.sap.com/2016/11/03/sap-nw-as-abap-7.50-sp2-developer-edition-to-download-consise-installation-guide/

Thanks guys,

B

10 |10000 characters needed characters left characters exceeded

Can u Share that error screen ?

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Nov 12, 2017 at 06:47 PM
0

Check YAST > Security and Users > Firewall: (X) Disable Firewall Automatic Starting and Current Status: Firewall is not running.


Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

@Tibor I had a look and my firewall is indeed disabled in opensuse.

0
avatar image
Former Member Nov 13, 2017 at 12:41 PM
0

Are you sure you need a port forwarding ?

Try on your open suse : telnet localhost:3200

if you have an answer the port is open, if you do not have an answer, check if your SAP is running (startsap ALL) and retry the telnet

if you are using the hostname in the windows, did you modify the file hosts of windows ? ( windows/drivers/etc/hosts something like that)

regards

Fred

Show 6 Share
10 |10000 characters needed characters left characters exceeded
Former Member

@Frederic I tried telnet localhost:3200 but it says "Name or service not known". SAP is definitely running and I ran startsap all again just in case. I also did try modifying the host file in Windows but that didn't help either...tried with and without the modified hosts file in windows.

0
Former Member

could you try to make a "netstat -apn | more". in the linux system & check if there is a port 3200 or 3201 .. ?

fred

0
Former Member

It doesn't look like there is port 3200 or 3201 listed there... I assume this is probably where my issue lies..

0
Former Member

should have :

tcp 0 0 0.0.0.0:3200 0.0.0.0:* LISTEN -

it's an extract from a SAP AS ABAP 7.51 SP2 – Developer Edition

0
Former Member

Ok I see what you mean but I"m not 100% sure on how to fix/ change it? Is it something I need to adjust in my linuxVM or is it possibly an SAP setting?

0
Former Member

If you didn't see the socket open (IP+port), for me, that means the server is not started

for helping you, you will have to give more log.

  • netstat -apn | grep 3200
  • telnet localhost:3200
  • startsap

(in file attachment)

fred

0