Skip to Content
author's profile photo Former Member
Former Member

No authorization to logon as trusted system (Trust ed RC=0)

Hi Guys,

I am working in CHARM implementation and i am facing a problem while importing the transport request from development to quality system.

once i select the pass correction to test action in urgent correction the system is giving an warning message(No import into test system has taken place yet).

When i go to task plan there the system is showing the transport request is succesfully released, but Import transport request as RED.

Description of the Error: System cancel RFC destination SM_QASCLNT410_TRUSTED, Call TMW_SET_PROJECT_SWITCHES: No authorization to logon as trusted system (Trust ed RC=0).

But when i do the pass correctio to test with SAP_ALL in Quality system it is successfully importing to quality system.

I have also assigned S_RFCACL to developer role in quality system. kindly give ur valuable inputs as it is very urgent.

Thanks&Regards

Raju

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 25, 2008 at 01:40 PM

    Hi,

    Check authorizations in S_RFCACL, I think you need to create Z role from S_RFCACL & maintain authorization for your development system.

    Regards,

    Rajesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 27, 2008 at 12:45 AM

    Penmetsa,

    Interesting name - trusted connections are somewhat interesting to work with - please check them by using the 'Remote Logon' button with the username check set to current user (if you are using a specific user, there is no real reason to use a trusted connection). When doing this, follow OSS Note: 128447 which is all the troubleshooting for Trusted Connections with all the return codes.

    From what you are showing with the RC=0, that is ususally authority - you probably don't have the role setup right on the QA system. Personally, I wouldn't bundle this because there are different flavors of this role that should be assigned to certain users. You should go check with your Security people for the best way to assign the proper credentials to end-users. A improperly configured S_RFCACL will allow one to access a remote system with a different userid!! Which is not really a good thing to have as a possiblity for daring developers that are looking for interesting things to play with.

    Anyhow - hope that helps, if it answers your question, please set the thread to answered.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 28, 2008 at 05:36 PM

    Raju,

    Actually looking at the return code - RC=0 is a system to system issue either with host-name resolution or you have missing message server port numbers in the services file (typical issue with this).

    You need to have the sapms<SID> <port> for the local system and the system you are trying to connect to with the Trusted Connection.

    Let us all know how it goes and additionally if this answers your question, please set this thread to answered.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Guys,

      The problem was solved, the user ID was locked so that is the reason it is not allowing me to login as a trsted RFC.anyhow thanks for your valuable inputs.

      Thanks&Regards

      Sitaramaraju.P

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.