Skip to Content

SAP Easy access menu in Fiori 2.0 not working

Nov 13, 2017 at 05:11 PM


avatar image

Hi Fiori experts,

I was trying to configure SAP Easy Access Menu in Fiori 2.0 launchpad which runs on S/4HANA 1610 on-premise embedded architecture.

I have followed each step as per the document (

I am able to get User Access Menu. However, SAP Menu throws error "Cannot get SAP menu Data: HTTP request failed"

I have created <system alias>_RFC and <system alias>_HTTP destinations in the system. Also activated User Menu and SAP Menu Odata service with required <system alias>

The odata: /sap/opu/odata/UI2/EASY_ACCESS_MENU/?$format=xml is giving 200 OK.

However, when I check the entity set MenuItems, the url not giving any data and error out with 500 connection time out error.

Please help me to troubleshoot the issue.



10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Bartosz Jarkowski Nov 13, 2017 at 05:39 PM

Usually, there is a lot of data to be returned by this OData service, which leads to Time Out.

Please implement following note and execute all steps listed there. It helped me a few weeks ago.

2449660 - SAP menu loads very slowly within SAP Fiori launchpad

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Bartosz,

The SAP Note 2449660 helped me to resolve the issue.

Also ran the report /UI2/NWBC_DELETE_MENU_CACHE after implementing the note.

Much appreciated.