Skip to Content
avatar image
Former Member

Hana Cloud Platform Predective Service/Database compatibility

After conducting the Hana XS database update , I got an error when starting the Predictive service indicating that there is some sort of incompatibility between the service and the database when binding the database.

Error: APL version is not compatible with the current version of APL4J.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 14, 2017 at 09:56 PM

    Hi Former Member,

    Only HANA MDC is currently supported on the SAP Cloud Platform trial landscape.

    This means that you can't the HANA XS shared instance on the trial landscape to run the SAP Predictive services.

    Hope this helps

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      If this a productive instance, then I highly recommend you to open a support ticket.

      The support team will most likely check which version of SAP HANA you are running and which version of the predictive service you are running.

      Each version of the predictive services is build toward one or multiple versions of APL. And each version of APL is compatible with one or multiple versions of SAP HANA.

      Therefore my guess is that you may have a version of APL, that is not compatible with the predictive services.

      By the way, have you checked the PAM?

      Regards

      @bdel