Skip to Content

Obrigatoriedade de uso do namespace 009 para Eventos após a Nota 2498688 ou SP28

Pessoal, bom dia.

Segundo a Nota SAP 2498688 (Activate NF-e Event Processing for NFE namespace 009) do SP28, ao aplicá-la ou aplicar o SP28 que está prestes a ser liberado, o uso do namespace 009 passa a ser obrigatório no SAP GRC NF-e (SLL-NFE) para emissão de Eventos, ou seja, estaremos impedidos de utilizar o namespace 008 para emissão de Eventos.

Tendo uma estratégia de go-live faseado, onde pretendemos colocar alguns CNPJ's na 4.00 e manter outros na 3.10, estamos preocupados em passar a utilizar o namespace 009 para emitir eventos de Notas que estarão sendo emitidas pelo namespace 008 (3.10).

Apesar de saber que o layout dos Eventos não mudou, a SEFAZ publicou novos WebServices para emissão de Eventos de Notas da 4.00, ou seja, manterá dois webservices de eventos ativos até o prazo final da versão 3.10. Já a SAP não, obrigará o uso do webservice novo via namespace (009) caso a nota 2498688 seja aplicada ou o SP28.

Mesmo que não tívessemos uma estratégia faseada, fica a preocupação. Imagina que a estratégia seja big bang, todos os CNPJ's de uma única vez para 4.00. Porém no primeiro dia do Go-Live eu preciso cancelar uma Nota emitida na versão 3.10, terei que fazê-lo pelo namespace 009 usando o novo webservice da SEFAZ, mesmo que minha Nota seja da 3.10.

A outra opção que seria não aplicar a Nota 2498688 ou o SP28, me faria ficar preso ao namespace 008 para Eventos, cujo qual também não tenho garantia que receberá eventos de notas da versão 4.00.

Já entrei em contato com a SAP via chamado e a resposta foi que não há possibilidade de usar o namespace 008 e 009 concomitantemente, apesar da SEFAZ permitir o uso de dois webservices de recebimento de eventos em paralelo por um período.

Gostaria de saber se alguém compartilha dessa preocupação e se vê uma saída para tal, ou se possui alguma informação que ajude a diminuir essa nossa preocupação.

Abraços a todos e obrigado desde já.

Pedro Baroni

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Nov 14, 2017 at 12:06 PM

    Oi Pedro,

    Eu fiz uns testes desse cenário e pela interface do 4.00 em homologação eu consigo autorizar eventos tanto de 3.10 como de 4.00 normalmente, então entendo que na produção o comportamento vai ser o mesmo.

    A SAP lançou hoje o SP28 e de fato eventos só com o namespace 009, então pra quem for entrar com o SP atualizado já vai ser 100% obrigatório mudar isso.

    att,

    Renan Correa

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 14, 2017 at 10:21 AM

    Pessoal, bom dia.

    Alguma informação adicional?

    Abraços.

    Baroni

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 08, 2017 at 01:06 AM

    Olá,

    alguem chegou a testar o serviço de RecepcaoEvento4 de MG ?

    Realizei emissão de uma nota 3.10 no sefaz de homolagacao de MG, como estamos com o SP 28 eu fiz a configuração do cenário do namespace 009 NFEEV_WebAs_Outbound_NFeEvent.

    Utilizei o WS https://hnfe.fazenda.mg.gov.br/nfe2/services/NFeRecepcaoEvento4 com o novo soapaction e esta me retornando o seguinte erro:

    Fiz a configuração do serviço RecepcaoEvento4 do estado de SP e fiz o mesmo procedimento, emissão de uma nota utilizando 3.10 e realizei a solicitação de cancelamento. Funcionou corretamente.

    Alguma dica ?

    Obrigado.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Ricardo,

      obrigado pela resposta, acredito que pode ajudar muitas pessoas.

      No meu caso ainda sigo esperando a resposta da SAP, qualquer novidade vou atualizar para documentar.

      Abraços.

  • avatar image
    Former Member
    Jan 14 at 11:31 PM

    Boa noite,

    com intuito de manter o post atualizado segue informações:

    fiz alguns testes no dia 10/01,11/01 e 12/01 e no ambiente de homologação funcionou corretamente.

    Att.

    Add comment
    10|10000 characters needed characters exceeded